Still problems with MacMail

Email setup and troubleshooting
Post Reply
ercatli
Posts: 116
Joined: Thu Apr 13, 2006 9:14 am
Location: Sydney
Contact:

Still problems with MacMail

Post by ercatli » Mon Apr 19, 2021 5:48 pm

I have reported this problem before. See viewtopic.php?f=13&t=46312&p=332768#p332768. I believe the problem is with Mac Mail, not Exetel, but I haven't been successful in getting any reply on a Mac forum. So I'm hoping someone can help me understand the problem at least.

I have two Exemail accounts. One works fine, the other receives emails but won't send. I have checked the settings based on Exetel "Email Clients Setup Guides" and they seem to be OK, though they are slightly different in each account (port and authentication).

When I try to send an email from the "bad" account, I get an error box saying (among other things): "Cannot send message using the server <my email address>. ..... The server response was: relay not permitted, authentication required".

So I tried to change the bad email port and authentication to be exactly the same as the working account, and when I tried to save the settings I got this error message: "A SMTP account already exists. Only a single SMTP account is allowed to be saved."

Is someone able to explain to me what these error messages might mean please"? (Like I said, I'm sure this is a Mac Mail problem, but if an Exetel person can explain the messages, I may be able to go to an Apple forum with more information.)

Thanks.

kavindip
Exetel Staff
Posts: 626
Joined: Wed Nov 07, 2018 6:05 pm

Re: Still problems with MacMail

Post by kavindip » Mon Apr 19, 2021 10:17 pm

ercatli wrote:
Mon Apr 19, 2021 5:48 pm
I have reported this problem before. See viewtopic.php?f=13&t=46312&p=332768#p332768. I believe the problem is with Mac Mail, not Exetel, but I haven't been successful in getting any reply on a Mac forum. So I'm hoping someone can help me understand the problem at least.

I have two Exemail accounts. One works fine, the other receives emails but won't send. I have checked the settings based on Exetel "Email Clients Setup Guides" and they seem to be OK, though they are slightly different in each account (port and authentication).
As per your explanation the issue you are currently experiencing does seem like it is related to Mac Mail.
ercatli wrote:
Mon Apr 19, 2021 5:48 pm

When I try to send an email from the "bad" account, I get an error box saying (among other things): "Cannot send message using the server <my email address>. ..... The server response was: relay not permitted, authentication required".
Some possibilities for this error to appear may be either the incorrect email credentials or settings are being used in the email account configuration in Mac Mail and SSL for the email account might be disabled.
ercatli wrote:
Mon Apr 19, 2021 5:48 pm

So I tried to change the bad email port and authentication to be exactly the same as the working account, and when I tried to save the settings I got this error message: "A SMTP account already exists. Only a single SMTP account is allowed to be saved."
According to what is stated in this error message it sounds like your email client, Mac Mail, does not allow multiple SMTP accounts to be set up simultaneously.

We suggest that you reset the entire email configuration for the bad email account on Mac Mail and reconfigure the account and check if the issue is resolved or test the email configuration on an alternate Apple device, if possible.

ercatli
Posts: 116
Joined: Thu Apr 13, 2006 9:14 am
Location: Sydney
Contact:

Re: Still problems with MacMail

Post by ercatli » Wed Apr 21, 2021 10:29 am

Thank you kavindip for your detailed reply.
We suggest that you reset the entire email configuration for the bad email account on Mac Mail and reconfigure the account and check if the issue is resolved or test the email configuration on an alternate Apple device, if possible.
This is the problem. We have two Macs using the problem email account, and the other one is working fine. My second account is also working fine. And the problem seems to be intermittent - since I wrote, I have tried to send 3 emails on the problem account - the first went OK (the first time in weeks I have been able to send), the second presented the same error message, and the third (a day later) went OK again. It is very hard to de-bug when the error is intermittent.

Anyway your reply has been helpful, and I am following up now on a Mac forum.

One remaining question please. What do you mean by "reconfigure"? I have tried to re-enter all the settings using the Exetel "Email Clients Setup Guides" page, but I run into the problem that Mac Mail won't allow this because it thinks it is a new SMTP account. Is there any way I can close the account and re-open it without losing my existing emails? I don't think that is possible is it?

Thanks again.

kavindip
Exetel Staff
Posts: 626
Joined: Wed Nov 07, 2018 6:05 pm

Re: Still problems with MacMail

Post by kavindip » Wed Apr 21, 2021 4:02 pm

ercatli wrote:
Wed Apr 21, 2021 10:29 am

This is the problem. We have two Macs using the problem email account, and the other one is working fine. My second account is also working fine. And the problem seems to be intermittent - since I wrote, I have tried to send 3 emails on the problem account - the first went OK (the first time in weeks I have been able to send), the second presented the same error message, and the third (a day later) went OK again. It is very hard to de-bug when the error is intermittent.

Anyway your reply has been helpful, and I am following up now on a Mac forum.

One remaining question please. What do you mean by "reconfigure"? I have tried to re-enter all the settings using the Exetel "Email Clients Setup Guides" page, but I run into the problem that Mac Mail won't allow this because it thinks it is a new SMTP account. Is there any way I can close the account and re-open it without losing my existing emails? I don't think that is possible is it?

Thanks again.
Since you have mentioned that this issue occurs intermittently, please check and confirm that the correct outgoing mail servers are set up on Mac Mail. If the device uses the internet service through different internet providers at different times then you may need to have the outgoing mail servers of the relevant ISPs set up on the email client to ensure that emails are sent out successfully.

Reconfiguring the email client account would mean deleting the concerned email account on Mac Mail and re-creating the email account with the relevant credentials and settings as per the Email Client Setup Guide. But that would delete the emails which are already saved on the Mac Mail email account at present.

ercatli
Posts: 116
Joined: Thu Apr 13, 2006 9:14 am
Location: Sydney
Contact:

Re: Still problems with MacMail

Post by ercatli » Wed Apr 21, 2021 10:39 pm

"please check and confirm that the correct outgoing mail servers are set up on Mac Mail"
No, the correct outgoing mail server IS NOT set because Mac Mail won't allow me to change it. At some stage in the past it was correct but somehow it was reset.
"If the device uses the internet service through different internet providers at different times then you may need to have the outgoing mail servers of the relevant ISPs set up on the email client to ensure that emails are sent out successfully."
I have 3 accounts on Mac Mail - one account that works fine, the one that isn't sending outgoing mail consistently, and a Gmail account, which also works fine.
"But that would delete the emails which are already saved on the Mac Mail email account at present."
That's what I thought. So I can't do that.

Thanks for your help. It is obviously a Mac Mail problem (Exetel webmail works OK) so you have helped as much as you can. I will now take it up with the Mac forum. Thanks again.

Post Reply