Email with Attachment not downloading.

Email setup and troubleshooting

Email with Attachment not downloading.

Postby John Baird on Thu Aug 06, 2015 2:59 pm

Can someone help with the following problem?
I have several email accounts set up with Thunderbird. For one of these accounts I have repeated occurrences of email from a particular source that remain on the mail server. I do get a partial content (truncated, just the company logo) email but without message content or notice of an attachment (usually on a bottom bar) nor a notice to enable a large download. The emails usually have an attachment (invoice, account) of about 190Kb. The account setting, Disk Space "Do not download messages larger than "X" for this account where X was initially set to 50Kb then 200Kb then 500Kb. The 500Kb setting allowed the full download.
Prior to the eventual download I went to my mail server and Forwarded the email to another of my email accounts, with Disk Space setting of 50Kb, which was received with attachment BUT the email content was shown as Source code. This reverted to normal when I selected View/Headers/Normal ( it had been set to All). Now this is a bit strange as normally when you select View/Headers/All only the header content changes?
Is this a TB bug or is something wrong with the email.

The truncated email that was first received:
From - Thu Jul 23 08:00:48 2015
X-Account-Key: account2
X-UIDL: 00000a27457fa25d
X-Mozilla-Status: 0401
X-Mozilla-Status2: 00000000
X-Mozilla-Keys:
Return-path: <noreply@originenergy.com.au>
Envelope-to: jpbbus@exemail.com.au
Delivery-date: Wed, 22 Jul 2015 21:58:24 +1000
Received: from chestnut2.exetel.com.au ([220.233.0.75])
by chestnut.exetel.com.au with esmtp (Exim 4.71)
(envelope-from <noreply@originenergy.com.au>)
id 1ZHsfI-00026s-6s
for jpbbus@exemail.com.au; Wed, 22 Jul 2015 21:58:24 +1000
Received: from ipmx2.po.exetel.com.au ([220.233.2.146] helo=mscip02.mailsentry.net.au)
by chestnut2.exetel.com.au with esmtp (Exim 4.71)
(envelope-from <noreply@originenergy.com.au>)
id 1ZHsfM-0003SE-0c
for jpbbus@exemail.com.au; Wed, 22 Jul 2015 21:58:28 +1000
X-IronPort-AV: E=Sophos;i="5.04,848,1406556000";
d="pdf'?scan'208,217";a="324750647"
Received: from mail1.bemta7.messagelabs.com ([216.82.254.102])
by mscip02.mailsentry.net.au with ESMTP; 22 Jul 2015 21:58:19 +1000
Received: from [216.82.253.163] by server-6.bemta-7.messagelabs.com id E6/44-30550-A558FA55; Wed, 22 Jul 2015 11:58:18 +0000
X-Env-Sender: noreply@originenergy.com.au
X-Msg-Ref: server-12.tower-166.messagelabs.com!1437566262!16903314!16
X-Originating-IP: [168.87.71.42]
X-StarScan-Received:
X-StarScan-Version: 6.13.16; banners=-,-,-
X-VirusChecked: Checked
Received: (qmail 29429 invoked from network); 22 Jul 2015 11:58:17 -0000
Received: from auamler1.mail.eds.com (HELO auamler1.mail.eds.com) (168.87.71.42)
by server-12.tower-166.messagelabs.com with DHE-RSA-AES256-SHA encrypted SMTP; 22 Jul 2015 11:58:17 -0000
Received: from auamler1.mail.eds.com (localhost [127.0.0.1])
by auamler1.mail.eds.com (8.14.9/8.13.8) with ESMTP id t6MBvIJK007604
for <jpbbus@exemail.com.au>; Wed, 22 Jul 2015 21:57:18 +1000
Received: from mail.originenergy.com.au ([203.20.196.13])
by auamler1.mail.eds.com (8.14.9/8.13.8) with ESMTP id t6MBvHwQ007597
(version=TLSv1/SSLv3 cipher=AES128-SHA bits=128 verify=FAIL)
for <jpbbus@exemail.com.au>; Wed, 22 Jul 2015 21:57:18 +1000
X-EDSCOD-Source-Ip: 203.20.196.13
X-Envelope-From: noreply@originenergy.com.au
Received: from AUSZOGESPWMP003.originenergy.com.au (10.215.1.33) by
mail.originenergy.com.au (10.215.0.29) with Microsoft SMTP Server (TLS) id
14.3.210.2; Wed, 22 Jul 2015 21:57:17 +1000
Received: from apuhi135.saporg.local (10.213.6.19) by
relay.originenergy.com.au (10.215.1.33) with Microsoft SMTP Server id
14.3.210.2; Wed, 22 Jul 2015 21:57:17 +1000
Date: Wed, 22 Jul 2015 21:57:17 +1000
From: =?ISO-8859-1?Q?Origin?= <noreply@originenergy.com.au>
Reply-To: <noreply@originenergy.com.au>
Subject: =?ISO-8859-1?Q?Your_Origin_Natural_Gas_e-bill_has_been_amended.?=
To: <jpbbus@exemail.com.au>
Message-ID: <28076.278.1022987.1437566237.265.0@originenergy.com.au>
MIME-Version: 1.0
Content-Type: multipart/mixed; boundary="1606532-18360-1437566237=:28076"

--1606532-18360-1437566237=:28076
Content-Type: text/html; charset="ISO-8859-1"
Content-Transfer-Encoding: QUOTED-PRINTABLE
Followed by some HTML content.

The following block preceded the Attachment that was eventually downloaded.
--1606532-18360-1437566237=:28076
Content-Type: application/pdf; name="=?ISO-8859-1?Q?Invoice.pdf?="
Content-Transfer-Encoding: BASE64
Content-Disposition: attachment
Followed by a large block of chars.
John Baird
 
Posts: 40
Joined: Fri Sep 23, 2005 11:36 am

Re: Email with Attachment not downloading.

Postby Dazzled on Thu Aug 06, 2015 4:45 pm

What happens if the relevant line becomes Content-Disposition: attachment; filename="filename.pdf" ?

It's coming through, but TB doesn't know what to do with it.
User avatar
Dazzled
Volunteer Site Admin
 
Posts: 6525
Joined: Mon Nov 13, 2006 1:16 pm
Location: Sydney

Re: Email with Attachment not downloading.

Postby John Baird on Thu Aug 06, 2015 5:09 pm

Hi Dazzled,
Thanks for looking at my problem.
I see what your saying, when I examined a successful attachment down load from another source it does have a file name in that place.
What is strange is that I could get it from the server by Forwarding it to another of my TB email account.
Also what (TB?) truncated the original download such that only the sources logo arrived?
So is the Senders email app. at fault or is the email being modified along the way and or is it just a bug in TB?
Note I am using TB on a Ubuntu system. Probably not relevant.
John Baird
 
Posts: 40
Joined: Fri Sep 23, 2005 11:36 am


Return to Email issues

Who is online

Users browsing this forum: No registered users and 1 guest