Unable to connect to webmail while using VPN

Email setup and troubleshooting
Post Reply
ohnjay
Posts: 44
Joined: Sun Apr 04, 2010 2:02 pm
Location: Sunshine Coast

Unable to connect to webmail while using VPN

Post by ohnjay » Mon Jun 03, 2019 3:16 pm

Today I have been unable to connect to webmail (both my hosted account and my exemail account) while my VPN is on.
It doesn't even take me to the login screen. I get a message "Performing TLS handshake" continuously.
As soon as I disable the VPN the login screen appears and I can read my emails.
If I enable the VPN after logging in, I get the "TLS hanshake message again"

I hope this is not intentional and will be fixed soon.

John

KavindaS
Forum Admin
Posts: 2506
Joined: Wed Dec 23, 2009 3:59 pm
Location: Sydney

Re: Unable to connect to webmail while using VPN

Post by KavindaS » Mon Jun 03, 2019 3:51 pm

ohnjay wrote:
Mon Jun 03, 2019 3:16 pm
Today I have been unable to connect to webmail (both my hosted account and my exemail account) while my VPN is on.
It doesn't even take me to the login screen. I get a message "Performing TLS handshake" continuously.
As soon as I disable the VPN the login screen appears and I can read my emails.
If I enable the VPN after logging in, I get the "TLS hanshake message again"

I hope this is not intentional and will be fixed soon.

John
Hi John,

Did you try using the following URLs?

https://hwebmail.exetel.com.au/src/login.php and https://webmail.exetel.com.au/

ohnjay
Posts: 44
Joined: Sun Apr 04, 2010 2:02 pm
Location: Sunshine Coast

Re: Unable to connect to webmail while using VPN

Post by ohnjay » Mon Jun 03, 2019 11:04 pm

Yes. I'll explain a little further:
I log on to webmail using Lastpass. The urls do not change whether I am on a VPN or not.
For clarity I have copied those urls from lastpass, they are - https://hwebmail.exetel.com.au and https://webmail.exetel.com.au.

This issue started today. I have been logging onto these two webmail accounts daily, without any problem, for several years, using the same VPN.
I have no difficulty accessing other webmail accounts hosted elsewhere. The problem is peculiar to Exetel.

I have tried used a different browser. I have tried using a different device. I have tried connecting by clicking the urls in your post..

None of this made any difference. The only thing that makes a difference is whether the VPN is active or inactive.

ohnjay
Posts: 44
Joined: Sun Apr 04, 2010 2:02 pm
Location: Sunshine Coast

Re: Unable to connect to webmail while using VPN

Post by ohnjay » Tue Jun 04, 2019 8:49 pm

More info on this:

I am able to download emails using Thunderbird while the VPN is on, so the problem happens only with webmail logins.

So, if I am away from home, using my mobile device with VPN on an unsecured public access point, I will be unable to use webmail. That is not a trivial matter.

ohnjay
Posts: 44
Joined: Sun Apr 04, 2010 2:02 pm
Location: Sunshine Coast

Re: Unable to connect to webmail while using VPN

Post by ohnjay » Wed Jun 05, 2019 12:42 pm

OK, so ths morning I logged into the member dashboard with my VPN running. As expected I was asked to verify using a token sent to my phone.
This is normal, and I logged in successfully.
Then I clicked the Webmail link on the dashboard page, and once more got the "TLS handshake" message..
I tried connecting to the forum page, and got exactly the same response. The connection eventually timed out.

So, if I can't read my webmail even when I am logged in to the members area, what is going on?
Some comment from Exetel's technical people would be welcome.

KavindaS
Forum Admin
Posts: 2506
Joined: Wed Dec 23, 2009 3:59 pm
Location: Sydney

Re: Unable to connect to webmail while using VPN

Post by KavindaS » Wed Jun 05, 2019 2:19 pm

ohnjay wrote:
Wed Jun 05, 2019 12:42 pm
OK, so ths morning I logged into the member dashboard with my VPN running. As expected I was asked to verify using a token sent to my phone.
This is normal, and I logged in successfully.
Then I clicked the Webmail link on the dashboard page, and once more got the "TLS handshake" message..
I tried connecting to the forum page, and got exactly the same response. The connection eventually timed out.

So, if I can't read my webmail even when I am logged in to the members area, what is going on?
Some comment from Exetel's technical people would be welcome.
I had a small conversation about this with our system administrators. They have confirmed, no recent changes were made with any of the conditions o restrict access. However, I will further escalate this in detail with them and provide you a feedback accordingly.

ohnjay
Posts: 44
Joined: Sun Apr 04, 2010 2:02 pm
Location: Sunshine Coast

Re: Unable to connect to webmail while using VPN

Post by ohnjay » Thu Jun 06, 2019 12:30 am

i have continued to pursue this at my end, and have found that it appears to be associated with only some VPN servers.
The VPN client I use is the same on each occasion.

If I use VPN servers at 139.99.208.34 and 168.1.83.136 I am unable to connect to webmail.
If I use servers at 31.24.225.7 or 58.96.36.116 I am able to log on to webmail.
Is the MSB of the first octet significant?

Coincidentally, when I log on to the members area via one of the first two servers I am required to provide a verification token, but when I log on using the server at 31.24.225.7 I am not asked for the the token. I haven't tested 31.24.225.7, but I predict that if I log on via that server I will not be asked for a token.

I should repeat here that this issue only happens with Exetel, both hosted email and exemail. The domains I have elsewhere do not have this problem, and I use the same VPN client and servers with them

KavindaS
Forum Admin
Posts: 2506
Joined: Wed Dec 23, 2009 3:59 pm
Location: Sydney

Re: Unable to connect to webmail while using VPN

Post by KavindaS » Thu Jun 06, 2019 5:06 pm

ohnjay wrote:
Thu Jun 06, 2019 12:30 am
i have continued to pursue this at my end, and have found that it appears to be associated with only some VPN servers.
The VPN client I use is the same on each occasion.

If I use VPN servers at 139.99.208.34 and 168.1.83.136 I am unable to connect to webmail.
If I use servers at 31.24.225.7 or 58.96.36.116 I am able to log on to webmail.
Is the MSB of the first octet significant?

Coincidentally, when I log on to the members area via one of the first two servers I am required to provide a verification token, but when I log on using the server at 31.24.225.7 I am not asked for the the token. I haven't tested 31.24.225.7, but I predict that if I log on via that server I will not be asked for a token.

I should repeat here that this issue only happens with Exetel, both hosted email and exemail. The domains I have elsewhere do not have this problem, and I use the same VPN client and servers with them
Thank you for providing the IP details, as this information I have planned to request from you today for further investigations. I have escalated this with our system administrators in detail for their investigations. Let me follow up this with them and provide you a feedback, under the ticket reference 15257166.

KavindaS
Forum Admin
Posts: 2506
Joined: Wed Dec 23, 2009 3:59 pm
Location: Sydney

Re: Unable to connect to webmail while using VPN

Post by KavindaS » Tue Jun 11, 2019 2:21 pm

I have received the response from the system administrators.

Based on their confirmation and the investigation completed, we do not block these IPs from our end.

Running trace route from your end is the best way to troubleshoot this, when you are connected with the VPN.

They have also suggested you to escalate this issue with your VPN provider.

Post Reply