Optimising Shaped Connections

Old, inactive threads
Post Reply
JasonM

Optimising Shaped Connections

Post by JasonM » Sat Jun 28, 2008 8:29 pm

If you are having problems browsing, and your connection is shaped, you may need to adjust some settings on your computer to allow better TCP functionality for the 64kbps speed.

Please note, this makes setting changes to your computer, and changing such settings is not supported by Exetel, it is entirely at your own risk.

There is an attachment to this post, "DR TCP". The ideal settings for a shaped connection are to set the MTU to 576 on the PC, and adjust the TCP Receive window to be 8 times the MTU.

The simple instructions for doing this are:

1. Open DR. TCP
2. In the TCP Receive Window, enter 4608.
3. In the MTU option, enter 576.
4. Ensure the Adapter Setting is set to the Network adapter connected to your modem. This will be "RealTek", "Intel", "3Com", "nVidia", or other select variants.
5. Click Save.
6. Reboot your computer.

Browsing should be able to cope a little better when shaped with the connection set to this.

You may need to reset the settings back to default after you are unshaped.
Attachments
DRTCP021.zip
Dr TCP - TCP Adjustment Tool.
(23.26 KiB) Downloaded 224 times

ccmmreid
Posts: 21
Joined: Sun May 04, 2008 2:27 pm
Location: Wanneroo, WA

Re: DR TCP - Shaped Connections

Post by ccmmreid » Sun Jun 29, 2008 1:27 pm

Thankyou very much JasonM

Web browsing when shaped was extremely painful.

Used this program:

TCPOptimizer

to alter settings and worked perfectly.

Now the pages will load in about 1/2 a minute, and not 1/2 an hour if at all.

Much apreciated!!! :D :D :D :D :D

Please make this a sticky for customers who are shaped.

Torydude
Posts: 1
Joined: Mon Jul 28, 2008 10:52 am
Location: Melbourne

Re: Optimising Shaped Connections

Post by Torydude » Mon Jul 28, 2008 11:05 am

Thanks for the post Jason, but it didn't do anything for me unfortunately. Shaping results in an unusable connection. I've been shaped with many ISPs before, and it's like being on reliable fast dial-up. Here I have trouble with my webmail, let-alone international sites :(

And can I politely say, you missed the most-important part -> How to undo. You mentioned resetting to default settings - But what are they?

ccmmreid
Posts: 21
Joined: Sun May 04, 2008 2:27 pm
Location: Wanneroo, WA

Re: Optimising Shaped Connections

Post by ccmmreid » Tue Jul 29, 2008 12:58 am

hi torydude,

before changing back to normal settings goto your modem settings page and set your mtu in there to 576, save then reset modem and computer.

Check your websites now.

I used tcpoptimizer to alter settings for mtu and tcp window
Select your network adapter for your modem/router.
Using optimal settings option you can select pppoe for mtu size which is 1492.
This should automatically set tcp window to 130680.
Then need to apply changes and select OK and reboot.

If you know how to go into your modem settings page then check the mtu settings in there as well.

Good luck :wink:

cryptwizard
Posts: 105
Joined: Tue Sep 28, 2004 8:16 am

Re: Optimising Shaped Connections

Post by cryptwizard » Sun Aug 31, 2008 8:08 am

Because I was too lazy to set the MTU on my computer (and hence have to reboot it), I set it on my router on the PPP link and the PPP session just drops and can't reconnect.
I could only reconnect after changing the MTU back to 1492.

Post Reply