TP Link W8980 - ethernet slower than wifi

Modem setup, reviews and questions (All brands, including wireless modems)
Post Reply
ohagas
Posts: 22
Joined: Tue Jun 19, 2007 9:38 pm
Location: Umina Beach, NSW

TP Link W8980 - ethernet slower than wifi

Post by ohagas » Mon Nov 18, 2013 10:23 pm

Hi
I have just installed a new TP Link w8980 modem router. I just used the setup CD supplied, and entered my modem username and password, and it installed OK.
However, after doing several speed tests I am getting around 3.5 Mbps on the desktop with a wired ethernet cable. On the laptop (or indeed the desktop using a wireless dongle) I'm getting around 5.5Mbps. Surely the cable should be faster than wireless? Are there any configuration settings I should change in the modem setup?
Thanks

User avatar
Dazzled
Volunteer Site Admin
Posts: 6002
Joined: Mon Nov 13, 2006 1:16 pm
Location: Sydney

Re: TP Link W8980 - ethernet slower than wifi

Post by Dazzled » Mon Nov 18, 2013 10:49 pm

Check the quick set up (manual p13). It should be default-
VPI 8
VCI 35
PPPoE
Exetel user name
Exetel password
For wireless, select 2.4 or 5GHz as wished
Australia/Auto/and the recommended security.

You should not be slow on ethernet from the modem onward. However a wireless dongle modem is using a different source (the mobile phone system) from an ADSL modem (the traditional wired phone system), and at any particular place speeds will differ. Your ADSL speed is largely dependent on the length of your phone line.

ohagas
Posts: 22
Joined: Tue Jun 19, 2007 9:38 pm
Location: Umina Beach, NSW

Re: TP Link W8980 - ethernet slower than wifi

Post by ohagas » Tue Nov 19, 2013 7:04 pm

Thanks Dazzled. Those settings seems to match with what I already had. I ran the quick setup again just to make sure.
The speed is still the same though - 3.5Mbps with the cable and 5.5Mbps wireless. I checked the driver on tmy Realtek NIC and that seems OK. (I'm running XP on the desktop).
I still don't understand how the wireless is faster than the cable (it's a new cable and less than a metre long)?

Also, I have both 2.4 and 5Ghz wireless frequencies enabled in the modem settings and they seem to be transmitting OK. However when I check for available wi-fi connections in the house I can only see the 2.4GHz SSID, and that's what I'm connected to. Does this mean I'm not picking up the other band?

User avatar
Dazzled
Volunteer Site Admin
Posts: 6002
Joined: Mon Nov 13, 2006 1:16 pm
Location: Sydney

Re: TP Link W8980 - ethernet slower than wifi

Post by Dazzled » Tue Nov 19, 2013 7:31 pm

I misunderstood your post, thinking you had separate internet sources. Wireless N and ethernet are both much faster than the ADSL source, and should not give the speed difference you see using the same modem as source. Short phone cables avoid picking up interference. Ethernet cables are differently constructed and don't have this problem.

You will only see the frequency band your hardware supports. I usually leave the computer at 2.4 and use a 5 GHz phone.

Check the hardware. Start with the cable and its plugs and sockets.

Post Reply