Which antivirus?

Malware detection, cleaning and prevention
User avatar
Tafkam
Posts: 323
Joined: Sat Nov 13, 2004 8:50 pm
Location: Northern Rivers NSW

Which antivirus?

Post by Tafkam » Sat Apr 04, 2009 11:19 am

What's the preferred free Antivirus program these days? Someone seems to blow a whistle every now & then and everyone changes. I'm using Avast at the moment, but it was locking up, so I uninstalled and am trying (as we speak) to download it again from their own website. I got it once and it was corrupted, so I'm trying again. If it does it again I'm going to have to look elsewhere.
Any suggestions appreciated.

User avatar
jokiin
Volunteer Site Admin
Posts: 2970
Joined: Mon Feb 02, 2004 10:23 pm
Location: Sydney

Re: Which antivirus?

Post by jokiin » Sat Apr 04, 2009 11:36 am

AVG seems popular for a free service

User avatar
Tafkam
Posts: 323
Joined: Sat Nov 13, 2004 8:50 pm
Location: Northern Rivers NSW

Re: Which antivirus?

Post by Tafkam » Sat Apr 04, 2009 11:44 am

Yeah I used to use AVG but changed to Avast some time ago when everyone said it was better (talk about a sheep, LOL). It was OK, too. If this file I'm downloading now is corrupt as well, I might go look up AVG again.

JasonM

Re: Which antivirus?

Post by JasonM » Sat Apr 04, 2009 11:46 am

Look at RAM issues if you get corrupt files, but no viruses found.

User avatar
Tafkam
Posts: 323
Joined: Sat Nov 13, 2004 8:50 pm
Location: Northern Rivers NSW

Re: Which antivirus?

Post by Tafkam » Sat Apr 04, 2009 11:55 am

The other thing that occurred at the same time that I installed Avast was that it now takes a dreadfully long time for the icons to appear on my desktop when I boot. The desktop pic comes up as normal, but it takes a good 3-5 minutes after that for the icons to appear. I uninstalled Avast thinking it was something to so with it, but it made no difference, so the timing must have been a coincidence. Jason...what RAM issues should I be looking for? Do you mean faulty RAM? If so, how do I check it?
Thanks....

User avatar
jokiin
Volunteer Site Admin
Posts: 2970
Joined: Mon Feb 02, 2004 10:23 pm
Location: Sydney

Re: Which antivirus?

Post by jokiin » Sat Apr 04, 2009 12:00 pm

Tafkam wrote:Do you mean faulty RAM? If so, how do I check it?
Thanks....
download Memtest86 (get the bootable CDiso) burn to disc and reboot with the disc in the drive (BIOS set to boot from disc) just let it run and do its thing and it will report any problems, very easy to follow

JasonM

Re: Which antivirus?

Post by JasonM » Sat Apr 04, 2009 12:02 pm

Tafkam wrote:The other thing that occurred at the same time that I installed Avast was that it now takes a dreadfully long time for the icons to appear on my desktop when I boot. The desktop pic comes up as normal, but it takes a good 3-5 minutes after that for the icons to appear. I uninstalled Avast thinking it was something to so with it, but it made no difference, so the timing must have been a coincidence. Jason...what RAM issues should I be looking for? Do you mean faulty RAM? If so, how do I check it?
Thanks....
Using a tool, such as memtest86, you can test the RAM in your computer. Your symptoms sound like faulty ram, but it's possible a virus could be causing it too.

If you have a Linux CD, they typically have a boot option for memtest, alternatively, you can download Memtest86 http://www.memtest86.com/
"Free Download" > "ISO image for creating bootable CD (Windows - zip)"

You'll need to extract it, and find a blank CD to burn the ISO to (Nero > "Burn Image"). Obviously, don't do this using the affected computer.
The alternative, if you are 'hardware savvy', would be to carefully remove one of the memory sticks, and see if the issue remains (only if you know hardware though).

User avatar
Dazzled
Volunteer Site Admin
Posts: 5997
Joined: Mon Nov 13, 2006 1:16 pm
Location: Sydney

Re: Which antivirus?

Post by Dazzled » Sat Apr 04, 2009 12:35 pm

Tafkam, wot Jason said. Didn't you once mention you had an Ubuntu Live CD lying around? Memtest is in its boot menu.

User avatar
Tafkam
Posts: 323
Joined: Sat Nov 13, 2004 8:50 pm
Location: Northern Rivers NSW

Re: Which antivirus?

Post by Tafkam » Sat Apr 04, 2009 12:39 pm

Crikeys Dazzled...you obviously don't need a Memtest! LOL Yes I have a Linux Puppy CD, and a Ubuntu one.

User avatar
Dazzled
Volunteer Site Admin
Posts: 5997
Joined: Mon Nov 13, 2006 1:16 pm
Location: Sydney

Re: Which antivirus?

Post by Dazzled » Sat Apr 04, 2009 12:46 pm

The ultra-useful Puppy can test your memory too..... Menu-->system-->memtest

User avatar
Tafkam
Posts: 323
Joined: Sat Nov 13, 2004 8:50 pm
Location: Northern Rivers NSW

Re: Which antivirus?

Post by Tafkam » Sat Apr 04, 2009 12:54 pm

Thank you so much guys. I have to fly off to work now but will Memtest ASAP. Will post back with results.

User avatar
Tafkam
Posts: 323
Joined: Sat Nov 13, 2004 8:50 pm
Location: Northern Rivers NSW

Re: Which antivirus?

Post by Tafkam » Mon May 04, 2009 8:22 am

Dazzled.....just letting you know I did a memtest from my new Ubuntu 9.04 (Jaunty Jackalope, of all things!!!) and all seems fine. The icons still take AGES to appear. I've done things like clear the Icon Chache etc, to no avail.
If anyone comes up with any more ideas to try...I"m listening!

User avatar
Dazzled
Volunteer Site Admin
Posts: 5997
Joined: Mon Nov 13, 2006 1:16 pm
Location: Sydney

Re: Which antivirus?

Post by Dazzled » Mon May 04, 2009 8:58 am

Might be a registry problem. Check out:

System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer]
Value Name: Max Cached Icons
Data Type: REG_SZ (String Value)
Value Data: 100 - 4096

(default setting is 500) Edit: This supposes you have icons to create at startup because cache isn't large enough.

User avatar
Tafkam
Posts: 323
Joined: Sat Nov 13, 2004 8:50 pm
Location: Northern Rivers NSW

Re: Which antivirus?

Post by Tafkam » Mon May 04, 2009 9:42 am

I'm wondering whether this shouldn't be moved out of the Anti-Virus forum now, lol.....

Anyway, Dazzled....
I couldn't find that it the registry anywhere so I added it, but it made no difference.
In doing so I noticed two other registry entries:

HideDesktopIcons
(Default) REG_SZ (value not set)

It has has two sub-folders:
ClassicStartMenu
(Default) REG_SZ (value not set)
{871C5380-42A0-1069-A2EA-08002B30309D}.default REG_SZ 0

NewStartPanel
(Default) REG_SZ (value not set)
{208D2C60-3AEA-1069-A2D7-08002B30309D} REG_DWORD 0x00000001 (1)
{20D04FE0-3AEA-1069-A2D8-08002B30309D} REG_DWORD 0x00000001 (1)
{450D8FBA-AD25-11D0-98A8-0800361B1103} REG_DWORD 0x00000001 (1)
{871C5380-42A0-1069-A2EA-08002B30309D} REG_DWORD 0x00000001 (1)

the other one:

HideMyComputerIcons
(Default) REG_SZ (value not set)
{21EC2020-3AEA-1069-A2DD-08002B30309D} REG_DWORD 0x00000001 (1)

Are these meant to be there and are they significant?

JasonM

Re: Which antivirus?

Post by JasonM » Mon May 04, 2009 9:56 am

Monitor disk activity on your system - the HDD LED light on the front, is that solid when this issue occurs?

Have you had your system networked with other machines, or is it still networked?

Post Reply