Virtual Mobile 'HTTP-POST' Notification Not Working?

WebSMS and 'Email to SMS' services
trk
Posts: 59
Joined: Fri Feb 12, 2010 12:38 am
Location: Brisbane

Re: Virtual Mobile 'HTTP-POST' Notification Not Working?

Post by trk » Mon Oct 18, 2010 12:09 pm

Slight update, the '<' character doesnt work either and truncates exactly the same as ampersand.

This would be consistent with a command line not being escaped correctly, given that '<' is another character used for console functions.

trk
Posts: 59
Joined: Fri Feb 12, 2010 12:38 am
Location: Brisbane

Re: Virtual Mobile 'HTTP-POST' Notification Not Working?

Post by trk » Thu Oct 21, 2010 8:14 pm

Hmm, I havent had a reply to the ticket yet which is now 5 days old.

How long do these sorts of queries normally take? Other support questions have been answered very promptly.

User avatar
Dazzled
Volunteer Site Admin
Posts: 5987
Joined: Mon Nov 13, 2006 1:16 pm
Location: Sydney

Re: Virtual Mobile 'HTTP-POST' Notification Not Working?

Post by Dazzled » Thu Oct 21, 2010 9:48 pm

I expect it might take a little longer as it's a question for the programmers. As I understand the problem, things like html <form> work, as also does specific encoding whether in php or a shell script. It pays to be careful with special characters and shell commands. How exactly do you send the messages that truncate?

User avatar
shoner
Forum Admin
Posts: 756
Joined: Mon Apr 20, 2009 2:50 pm

Re: Virtual Mobile 'HTTP-POST' Notification Not Working?

Post by shoner » Thu Oct 21, 2010 10:52 pm

trk wrote:Hmm, I havent had a reply to the ticket yet which is now 5 days old.

How long do these sorts of queries normally take? Other support questions have been answered very promptly.
Hi trk,

Could you kindly let me know the ticket #? I could follow this up for you.

Thanks
"Helping Making a Better World"

Log a fault ticket Here
or call Exetel VOIP numbers (02) 8030 1000 or 1300 788 141 (log faults 24x7)
Exetel Support Portal

trk
Posts: 59
Joined: Fri Feb 12, 2010 12:38 am
Location: Brisbane

Re: Virtual Mobile 'HTTP-POST' Notification Not Working?

Post by trk » Thu Oct 21, 2010 11:51 pm

Dazzled wrote: How exactly do you send the messages that truncate?
.... via SMS, either from my phone, someone elses phone, Exetels web SMS, Pennytel's web SMS, any other standard form of SMS sending.

Its the Exetel Virtual Mobile Number SMS -> HTTP POST notification that is the issue here (the URL for the notification is inputted into the Virtual Mobile Number section of the control panel)


EDIT: Added screenshot for clarity
Image
Last edited by trk on Thu Oct 21, 2010 11:58 pm, edited 1 time in total.

trk
Posts: 59
Joined: Fri Feb 12, 2010 12:38 am
Location: Brisbane

Re: Virtual Mobile 'HTTP-POST' Notification Not Working?

Post by trk » Thu Oct 21, 2010 11:56 pm

shoner wrote:
trk wrote:Hmm, I havent had a reply to the ticket yet which is now 5 days old.

How long do these sorts of queries normally take? Other support questions have been answered very promptly.
Hi trk,

Could you kindly let me know the ticket #? I could follow this up for you.

Thanks
Hi shoner,

The 'mask' is BII-85229-339... I assume thats the ticket number?

There is now far more information in this thread than in that ticket though.

Thanks for any followup. Aside from the '&' and '<' symbols (possibly others) truncating messages, the system works well. I get the notification email (with all characters, including & and < inside) correctly and AFAIK no SMS's have been dropped yet and theres probably been 100-odd received messages (EDIT: I just looked it up, its 252 messages... heh.... :D)

I'd still love to be able to put a message bank style voicemail/recorded message against that virtual number, if you know of a way to do that? Not for actually receiving any messages or anything, but just to be able to say 'thanks for calling, this service is for texts only. If you require assistance call our office on blahblahblah' to let people know instead of it just not connecting.

JanakaDS
Exetel Staff
Posts: 119
Joined: Fri May 11, 2007 1:00 pm

Re: Virtual Mobile 'HTTP-POST' Notification Not Working?

Post by JanakaDS » Fri Oct 22, 2010 9:49 am

trk wrote:
shoner wrote:
trk wrote: The 'mask' is BII-85229-339... I assume thats the ticket number?
Please find that it is not the exact Ticket number and unfortunately I'm unable to find out your ticket with this details. Would you please send an email from your nominated email address to residentialsupport@exetel.com.au with this URL so I can search all tickets related to your issue and investigate further?

trk
Posts: 59
Joined: Fri Feb 12, 2010 12:38 am
Location: Brisbane

Re: Virtual Mobile 'HTTP-POST' Notification Not Working?

Post by trk » Fri Oct 22, 2010 10:13 am

trk wrote: The 'mask' is BII-85229-339... I assume thats the ticket number?
Please find that it is not the exact Ticket number and unfortunately I'm unable to find out your ticket with this details. Would you please send an email from your nominated email address to residentialsupport@exetel.com.au with this URL so I can search all tickets related to your issue and investigate further?
Sorry, I just check back through my email inbox and found the automated response to my support ticket which shows the number.

Its #3362406#

Thanks!

JanakaDS
Exetel Staff
Posts: 119
Joined: Fri May 11, 2007 1:00 pm

Re: Virtual Mobile 'HTTP-POST' Notification Not Working?

Post by JanakaDS » Fri Oct 22, 2010 10:38 am

trk wrote:
trk wrote:
Sorry, I just check back through my email inbox and found the automated response to my support ticket which shows the number.

Its #3362406#

Thanks!
Thank you for information.
I can see that our Developers are currently investigating your issue. You will be notified with an update via the same email ASAP.

trk
Posts: 59
Joined: Fri Feb 12, 2010 12:38 am
Location: Brisbane

Re: Virtual Mobile 'HTTP-POST' Notification Not Working?

Post by trk » Fri Oct 22, 2010 11:54 am

JanakaDS wrote: Thank you for information.
I can see that our Developers are currently investigating your issue. You will be notified with an update via the same email ASAP.
Great, thanks for the update :D

I dont want to be "that guy" who is the annoying customer that is constantly pestering for updates, but I'm surprised noone else has noticed/complained of this before? Are not many people using the HTTP POST notification method for SMS? Or maybe they dont really get odd characters like '&' and '<' in their SMSs :\

raymond
Exetel Staff
Posts: 345
Joined: Thu Mar 04, 2004 2:46 pm

Re: Virtual Mobile 'HTTP-POST' Notification Not Working?

Post by raymond » Fri Oct 22, 2010 4:49 pm

It looks like issue with our supplier end.

SMS send out via our gateway. Message then delivery to your virtual mobile number via our supplier network. For some unknow reason, the message has been encoded incorrectly.

We will raised the issue in our supplier end.

trk
Posts: 59
Joined: Fri Feb 12, 2010 12:38 am
Location: Brisbane

Re: Virtual Mobile 'HTTP-POST' Notification Not Working?

Post by trk » Fri Oct 22, 2010 8:00 pm

Sounds good, thanks :)

trk
Posts: 59
Joined: Fri Feb 12, 2010 12:38 am
Location: Brisbane

Re: Virtual Mobile 'HTTP-POST' Notification Not Working?

Post by trk » Wed Oct 27, 2010 7:35 pm

Hmm, well I never got an email.... and although the ticket says it was updated 5 hours ago theres no reply / extra information in it thats viewable by me...... But it appears to be working now, as I just sent a test message with an ampersand in it that was correctly received by the PHP file on my host :D

So thanks for the fix, though the communication that it was done could have been better :P

William M
Posts: 510
Joined: Wed Mar 21, 2007 1:28 pm

Re: Virtual Mobile 'HTTP-POST' Notification Not Working?

Post by William M » Thu Oct 28, 2010 9:01 am

Hi,

Currently we are still working with our provider to identify the issue with the ">" character.

Cheers

Post Reply