Page 1 of 8

FireFox Usage Meter

Posted: Sun Jul 18, 2004 5:41 pm
by Shutty

A fellow has coded an extention (add-in) for FireFox to display a usage meter. He has tried to add Exetel to the list of ISP's that can display the usage but is having trouble. Here is a message he wrote on whirpool:
Hi Exetel users,

Here's is the thing with the exetel support:

1) The login issue, where you have to login to update the usage is the bug - which I'm currently unable to find a solution, and I'll elaborate further later.

2) Because the exetel usage page does not show the starting day and quota, and all the details are scraped from there, you have to manually enter the usage.

3) The XML undefined entity bug is due to a locale path mistake in previous versions of the install script (eg. 051) and only affects in non-firefox0.9+ mozillas - but it should be fixed in 054b. I'm guessing, the reason you are experiencing it is that you have previous versions of the extension installed and attempted to do an upgrade - Mozilla doesn't update its installed-chrome.txt, so bug is still present. Since the new version uses dtd entities and old ver. doesn't, bug rears its ugly head.
To fix, uninstall the extension with the instructions at:
and perform an install with 054b again.

Now regarding problem 1) - if you don't want to be bored off with technical details, you can skip this paragraph. To login to the exetel usage page, the extension needs to perform a HTTP POST request. Now one arcane requirement of POST is the need to have the POST data sent in a seperate packet. The emulated POST requests of the netusage extension cannot/does not do that due to bugs in the mozilla code. Luckily, nearly all ISPs which uses POST auth doesn't require this. Unfortunately, I've reached a roadblock here, whereby the exetel server does seem to require this.

To fix, I'll need to contact exetel (to get them to change their server config? unlikely) or post a mozilla bug and wait for a eventual patch to be posted. Both which I do not currently have the time and will for.

I will release a new version tomorrow which has this partial exetel support. If a technical minded exetel user can look into this more, I'm sure everyone would be grateful.
Any change that these mods can be made so us FireFox users can use this extension?

BTW this is the extension here:

Cheers Shutty

Edit by Gidget - thread made a Sticky

Posted: Mon Jul 19, 2004 3:39 pm
by Adrenal
Buddy, it already has. Check my thread in service suggestions

Posted: Mon Aug 23, 2004 4:24 pm
by Gidget
Good news for all you Firefox users out there - the Net Usage Meter has now been fixed so that you can retrieve your usage figures without having to log into the Members page first.

You need Version 0.5.8 of the Meter, which is available here

Thank you to all concerned.



Posted: Fri Sep 10, 2004 9:30 pm
by doggy
The updated version also works in Mozilla 1.7.


Posted: Sat Sep 18, 2004 8:51 pm
by pongie
This might eb a silly question but what is the username and password?

Do I use the login to the members site or the exetel's connection?

I keep getting a login failed error

Posted: Sat Sep 18, 2004 8:55 pm
by Gidget
Hi Pongie

You use the username and password for the Members Facilities.



Posted: Sat Sep 18, 2004 9:00 pm
by pongie
I dont know but I must be doing something wrong... it still say the login is incorrect.

I even copy and pasted the details from the settings in to the login (via web) and that seems to be fine.

Is there a step I'm missing?

Posted: Sat Sep 18, 2004 10:01 pm
by Gidget
Hi Pongie

Probably a stupid question, but you have selected Exetel from the drop down ISP list in Preferences?

Can you log-in okay to the Member Facilities page using the same username and password that you are using in NetUsage Meter?

Do you have Version 0.5.8 of the Meter?



Posted: Sat Sep 18, 2004 10:24 pm
by pongie
Yes I have selected exetel...

Am I supposed to leave the details about usage blank?

I can log in fine with the web browser but the meter does not.

I thought I mispelled the details so I copied and pasted the user name and password into the webpage and tried loging in manually.

That worked fine... so I don't know what is wrong.

oh yes, it is version 0.5.8

I'm on unwired, through exetel, does this matter?

Posted: Sat Sep 18, 2004 10:34 pm
by Gidget
Hi Pongie

You do need to fill in your usage details, as the Meter can't read these from the usage page. I wouldn't have thought the lack of them would give you a log-in failure though.

Likewise, I don't see that being on the unwired service should matter - the meter only reads the same info you can access successfully through the member facilities page.

Have you dragged the Meter onto your Firefox toolbar?

Often when it does its two-hourly (in my case) checks I get the red cross and it says ISP usage source could not be parsed correctly. If that happens, I just click on it again and it usually comes good (not that it matters since the meter is only updated at Exetel's end once a day at the moment).



Posted: Sat Sep 18, 2004 10:47 pm
by pongie
Yes I see the meter but it has has a red cross.

no matter how many times I click on it it just goes green arrow for about 2-5 secs before a red cross again.

Posted: Sat Sep 18, 2004 10:55 pm
by Gidget
... and I guess (going back to your first post) that the error message you get is "incorrect login" or similar?

Posted: Sat Sep 18, 2004 11:18 pm
by pongie
"login failed. wromg username or password"

Actually I cant even get in with my web browser anymore....

Have clicked on forgot password link and hopefully that would work.

Maybe my account got suspendee/deactivated for too many incorrect attempts? Dunno but I got in fine like 1-2 hrs ago

Posted: Sat Sep 18, 2004 11:22 pm
by pongie
Just got an email rfom exetel support and their reply was I dot have an account there...

I checked the web page address and I was trying to log on to the member's facilities of ADSL.

So when I went to Wireless' page I logged in fine.

Therefore I assume the meter on google only works for ADSL then since it's probably trying to login to the non wireless page and is getting errors.

Posted: Sat Sep 18, 2004 11:35 pm
by Gidget
Oh I see - sorry :oops: I didn't realise they were two different pages.

You could ask the NetUsage author to do a wireless version too - he's pretty amenable to requests.