Page 1 of 3

usagemeter_xml.php and billing date changes

Posted: Mon Mar 28, 2011 8:46 am
by peber
Hey folks,
Just wondering if anyone has had problems with the usagemeter_xml.php not returning the correct usage values since their billing date has changed?
As an example, here is what I'm getting back when I hit https://www.exetel.com.au/members/usagemeter_xml.php
(Irrelevant stuff has been trimmed):
<PlanDetails>
<PeakTimeDownloadInMB>200000</PeakTimeDownloadInMB>
<OffpeakTimeDownloadInMB>0</OffpeakTimeDownloadInMB>
</PlanDetails>
<CurrentMonthUsage>
<PeakDownload>10938.1</PeakDownload>
<OffpeakDownload>12075.2</OffpeakDownload>
<UpdateDatetime>2011-03-28 07:47:46 AEDST</UpdateDatetime>
</CurrentMonthUsage>

My usage reset last night in line with the new billing date, and my members page shows the reset usage, so this seems to just be the usagemeter_xml.php script.
Is there an issue with the script or am I just being impatient and it will come good itself? :)


cheers,
Peber.

Re: usagemeter_xml.php and billing date changes

Posted: Mon Mar 28, 2011 10:48 am
by TheToid
I noticed this too Peber, this is what my XML file shows (at 9.30am Brisbane time on the 28-03-2011, it hasnt reset yet, but the exetel webpage has):

<ContractDetails>
<ContractStartDate> 2010-01-11</ContractStartDate>
<ContractPeriod> 30 Days</ContractPeriod>
<ContractEndDate> 2010-02-11</ContractEndDate>
</ContractDetails>
<PlanDetails>
<PlanName>TE-2D</PlanName>
<LineSpeed> 100000</LineSpeed>
<PeakTimeDownloadInMB> 100000</PeakTimeDownloadInMB>
<OffpeakTimeDownloadInMB> 120000</OffpeakTimeDownloadInMB>
<PeakShaping>NO</PeakShaping>
<OffpeakShaping>NO</OffpeakShaping>
<PlanPrice>$ 68.00</PlanPrice>
<ExtraDownloadPerGB>$1.00</ExtraDownloadPerGB>
</PlanDetails>
<IPAddress> xxx.xxx.xxx.xxx</IPAddress>
<CurrentMonthUsage>
<PeakDownload> 86622.17</PeakDownload>
<PeakUpload> 46414.95</PeakUpload>
<OffpeakDownload> 116761.22</OffpeakDownload>
<OffpeakUpload> 65260.74</OffpeakUpload>
<UpdateDatetime> 2011-03-28 09:06:37 AEDST</UpdateDatetime>
</CurrentMonthUsage>

Pretty shockingly poor effort on Exetels' part not to make sure its updated BEFORE the rollout of the new billing period, i hope they fix it soon.

While your at it exetel, can you please fix the issue in the XML file with the OCVxxx and TCVxxx plans as well, the problem is, the data is still being seperated by Off-Peak and Peak yet these plans have no off-peak and peak, and my program has no way to detect if the plans are this way or not, it would be great if you left the Off-Peak BLANK, thats right BLANK not 0, and put all the downloaded data into the PEAK field in the XML file. If you make these changes for all the plans which dont have the Peak / Off-Peak data, my meter will automatically detect it is a Peak only plan and automatically update. Thankyou.

Please fix this soon exetel.

Re: usagemeter_xml.php and billing date changes

Posted: Mon Mar 28, 2011 12:50 pm
by Dazzled
The start date can be picked up from //Daily, although a new element may be easier.

The main difficulty at the moment is that the meter coder has to know in advance that certain values of //PlanName (ie OCV*, TCV*) require the peak and off peak values to be added together to display the information most important to the user.

//PlanDetails/OffpeakTimeDownloadInMB (0 for OCV plans) tells whether the offpeak field is of interest. 0 is not unique to OCV plans, we also used this for older no-quota plans . One useful approach would be a new element in PlanDetails which explicitly flags the need to sum the values (no secret knowledge required).

Exetel could also provide a new element, say //CurrentMonthUsage/TotalDownload, giving the total. This may be a more flexible long term solution as plans develop.

The problem for the unofficial meters (mine too) is that they were designed to use the peak usage graph to do double duty. Setting the offpeak numerical value null or a blank string isn't the way.

Re: usagemeter_xml.php and billing date changes

Posted: Mon Mar 28, 2011 1:16 pm
by peber
Thats sort of useful for working out the start date, etc.

The problem here is that "<CurrentMonthUsage>" isn't providing the correct values - what we need is a "<CurrentPeriodUsage>" :wink:

Re: usagemeter_xml.php and billing date changes

Posted: Mon Mar 28, 2011 6:07 pm
by TheToid
Definitely, they need to fix the file up, I was the one who actually initiated the creation of the XML URL, because too many people were using my program and it was hitting the website too often and i was getting into trouble because the Exetel website was under strain, so i hope they fix it soon, or I may have to change it back

Re: usagemeter_xml.php and billing date changes

Posted: Tue Mar 29, 2011 7:55 pm
by TheToid
Because i havnt recieved any reply from anyone at exetel in these forums, i have raised a Help Desk Ticket, lets hope they fix it now :)

Re: usagemeter_xml.php and billing date changes

Posted: Tue Mar 29, 2011 9:19 pm
by thejeg
Hi All,

I have requested for a member of the developer team to ahve a look at this.

He will investigate and update this thread accordingly.

Regards,
Theje

Re: usagemeter_xml.php and billing date changes

Posted: Tue Mar 29, 2011 10:37 pm
by thejeg
HI All,

According to our developer team, this is already identified, and they are working on fixing this issue ASAP.

Regards,
Theje

Re: usagemeter_xml.php and billing date changes

Posted: Fri Apr 01, 2011 10:05 pm
by Chris T
It looks like that the detail usage page has been fixed. Thanks.

Can I request we have the option to enter the year and month in the end date of the customer usage query as we need to do for the start date please? The way the usage query is configured right now, those of us with the billing period not aligned with the calendar months will not be able to query the usage for the previous billing period come next billing cycle.

Thanks,
Chris.

Re: usagemeter_xml.php and billing date changes

Posted: Thu Apr 07, 2011 11:49 pm
by GaryG
So just to confirm the xml page is sorted for plans that start on days other than 1st of the month?

Just wondering as NetUsage for Firefox is still having problems which I guess means something needs changing in the meter.

Re: usagemeter_xml.php and billing date changes

Posted: Fri Apr 08, 2011 10:39 am
by peber
No, there has been no confirmation from Exetel that the XML data has been corrected.
I just checked and the XML information is still wrong.

I think Chris T was referring to the usage page in the members section, not the XML source.

Re: usagemeter_xml.php and billing date changes

Posted: Fri Apr 08, 2011 11:01 am
by GaryG
peber wrote:No, there has been no confirmation from Exetel that the XML data has been corrected.
I just checked and the XML information is still wrong.

I think Chris T was referring to the usage page in the members section, not the XML source.
Thanks for that clarification.

Re: usagemeter_xml.php and billing date changes

Posted: Thu Apr 28, 2011 10:55 pm
by StrawHat
TheToid wrote:Because i havnt recieved any reply from anyone at exetel in these forums, i have raised a Help Desk Ticket, lets hope they fix it now :)
Any response on that ticket TheToid? This is annoying to say the least. I assume your usage meter uses this data aswell so it must be heaps of fun for you.
Can you let us know if you go back to the old grab. I'm tipping that will happen first :roll:

Re: usagemeter_xml.php and billing date changes

Posted: Fri Apr 29, 2011 11:52 am
by thejeg
StrawHat wrote:
TheToid wrote:Because i havnt recieved any reply from anyone at exetel in these forums, i have raised a Help Desk Ticket, lets hope they fix it now :)
Any response on that ticket TheToid? This is annoying to say the least. I assume your usage meter uses this data aswell so it must be heaps of fun for you.
Can you let us know if you go back to the old grab. I'm tipping that will happen first :roll:
This issue as I mentioned earlier is being looked in to...... and will be fixed by the course of next week

Re: usagemeter_xml.php and billing date changes

Posted: Fri Apr 29, 2011 12:57 pm
by Need2No
thejeg wrote:
StrawHat wrote:
TheToid wrote:Because i havnt recieved any reply from anyone at exetel in these forums, i have raised a Help Desk Ticket, lets hope they fix it now :)
Any response on that ticket TheToid? This is annoying to say the least. I assume your usage meter uses this data aswell so it must be heaps of fun for you.
Can you let us know if you go back to the old grab. I'm tipping that will happen first :roll:
This issue as I mentioned earlier is being looked in to...... and will be fixed by the course of next week
Would be nice that whilst the developers are looking into that problem, that they could also look into supplying the CAP plan data in xml format as well.

Regards