hspa xml usage not working

Queries, errors or glitches regarding Member facilities
Post Reply
Dimand
Posts: 36
Joined: Fri Jun 11, 2010 12:41 am
Location: Newcastle

hspa xml usage not working

Post by Dimand » Thu Nov 24, 2011 12:39 am

I am on the following plan: Monthly Plan : WM - C

Technically this is a HSPA mobile internet plan however i use it in my phone (I use a fair bit of mobile data, it also lets me make calls text etc tec)

I am trying to use this link to get the xml data:
https://www.exetel.com.au/hspa/hspa_usa ... 2011-07-18

And I get this response:
The Service Not Found.
Any help on how to get this working would be appreciated.

raymond
Exetel Staff
Posts: 345
Joined: Thu Mar 04, 2004 2:46 pm

Re: hspa xml usage not working

Post by raymond » Thu Nov 24, 2011 11:19 am

The Usage link is mainly for mobile user. The detailed call usage data is from Optus 3G network.

For mobile broadband, the usage is directly from Exetel LNS router.

We will make further change to include it in the usage link.

Dimand
Posts: 36
Joined: Fri Jun 11, 2010 12:41 am
Location: Newcastle

Re: hspa xml usage not working

Post by Dimand » Thu Nov 24, 2011 12:20 pm

Thank you.

While I'm here I might as well request the following features.
I'm hoping that the hspa_usage_xml.php link gives you a monthly summary for the current month that you enter the date into as well as the details for that day. This way usage programs wont have to cycle through each day of the month to add up the total usage. I'm also hoping that it lets you know the call/sms usage of your sim card. If this is already implemented thanks in advance.

Also, a link that gives you a summary of the number of web based sms sent that month would be very helpful (had a look through the sms api but couldn't find anything useful in this matter). xml data for voip accounts would also be very useful. This way it makes it very easy to write programs to display the monthly data on your phone or desktop and you don't have to curl into the member facilities and rewrite the program every time the members user interface changes.

Not trying to be demanding, I can live without these things and they are simply a luxury, however I think such things would make your more advanced user base very happy.
:D

rukshani
Exetel Staff
Posts: 275
Joined: Tue Oct 19, 2010 4:54 pm

Re: hspa xml usage not working

Post by rukshani » Thu Nov 24, 2011 3:33 pm

Dimand wrote:Thank you.

While I'm here I might as well request the following features.
I'm hoping that the hspa_usage_xml.php link gives you a monthly summary for the current month that you enter the date into as well as the details for that day. This way usage programs wont have to cycle through each day of the month to add up the total usage. I'm also hoping that it lets you know the call/sms usage of your sim card. If this is already implemented thanks in advance.

Also, a link that gives you a summary of the number of web based sms sent that month would be very helpful (had a look through the sms api but couldn't find anything useful in this matter). xml data for voip accounts would also be very useful. This way it makes it very easy to write programs to display the monthly data on your phone or desktop and you don't have to curl into the member facilities and rewrite the program every time the members user interface changes.

Not trying to be demanding, I can live without these things and they are simply a luxury, however I think such things would make your more advanced user base very happy.
:D
Thank you for your valuable comments, we most certainly will work on these and I will personally send you an email when the proposed changes are implemented.

Dimand
Posts: 36
Joined: Fri Jun 11, 2010 12:41 am
Location: Newcastle

Re: hspa xml usage not working

Post by Dimand » Thu Nov 24, 2011 4:15 pm

rukshani wrote: Thank you for your valuable comments, we most certainly will work on these and I will personally send you an email when the proposed changes are implemented.
Thank you. I look forward to hearing from you.

Post Reply