Page 1 of 2

XML Usage Meter/Data

Posted: Mon Jul 28, 2014 7:55 pm
by kudabird
Hello Exetel,

Since the shift to 14th of month for start of billing cycle (data usage), the XML usage data is incorrect. In my case it still reflects usages starting at 1st month and hence shows incorrect data usage for the billing period. Is the XML usage data going to be corrected at all to reflect the new billing start date? I depend on the XML data for usage monitoring.

Andrew.

Re: XML Usage Meter/Data

Posted: Mon Jul 28, 2014 8:25 pm
by Dazzled
Pending a fix I parsed "//Daily" and summed the fields for the required dates.

Re: XML Usage Meter/Data

Posted: Tue Jul 29, 2014 11:19 am
by kudabird
Hi Dazzled. I don't think that will work. In a few days we will switch to August and the XML wont contain July data which is what would be needed for your workaround to be valid. The section <MonthlyUsage> now needs to reflect data usage for the month starting on 14th and not the first.

Re: XML Usage Meter/Data

Posted: Tue Jul 29, 2014 2:57 pm
by Dazzled
Sorry I wasn't more expansive. I save the XML, and the running totals. It's a horrible patch to my script. After Exetel fixes this, I might (I hope) get round to updating the meter I published here yonks ago, that shows daily downloads.

Re: XML Usage Meter/Data

Posted: Thu Jul 31, 2014 11:13 pm
by ShaminG
Our development team is working on this. Will get sorted out within next week.

Re: XML Usage Meter/Data

Posted: Fri Aug 01, 2014 10:37 am
by kudabird
ShaminG wrote:Our development team is working on this. Will get sorted out within next week.
Hello. Thanks for the update. Whilst the developers are at it, is the any chance they could corrected the data within <LineSpeed> as per the sample below. For as long as I can remember (years) this field has always displayed the MB allowance for some reason.

<PlanDetails>
<PlanName>OT-10</PlanName>
<LineSpeed>10000</LineSpeed>
<PeakTimeDownloadInMB>10000</PeakTimeDownloadInMB>
<OffpeakTimeDownloadInMB>10000</OffpeakTimeDownloadInMB>
<PeakShaping>NO</PeakShaping>
<OffpeakShaping>NO</OffpeakShaping>
<PlanPrice>$29.50</PlanPrice>
<ExtraDownloadPerGB>$0.50</ExtraDownloadPerGB>
</PlanDetails>

Re: XML Usage Meter/Data

Posted: Fri Aug 01, 2014 10:45 am
by Dazzled
It's a pointless entry. The required information is at //PlanDetails/OffpeakTimeDownloadInMB and at //PlanDetails/PeakTimeDownloadInMB

Re: XML Usage Meter/Data

Posted: Fri Aug 01, 2014 10:47 am
by ShaminG
Hello. Thanks for the update. Whilst the developers are at it, is the any chance they could corrected the data within <LineSpeed> as per the sample below. For as long as I can remember (years) this field has always displayed the MB allowance for some reason.

<PlanDetails>
<PlanName>OT-10</PlanName>
<LineSpeed>10000</LineSpeed>
<PeakTimeDownloadInMB>10000</PeakTimeDownloadInMB>
<OffpeakTimeDownloadInMB>10000</OffpeakTimeDownloadInMB>
<PeakShaping>NO</PeakShaping>
<OffpeakShaping>NO</OffpeakShaping>
<PlanPrice>$29.50</PlanPrice>
<ExtraDownloadPerGB>$0.50</ExtraDownloadPerGB>
</PlanDetails>
I have asked our development team to look into this as well.

Re: XML Usage Meter/Data

Posted: Fri Aug 15, 2014 8:42 am
by angelos
We have received confirmation that this has been fixed. Please reply to this post if you have any further issues in this regard.

Re: XML Usage Meter/Data

Posted: Fri Aug 15, 2014 10:41 am
by Dazzled
It's was still running from the 1st of the month this morning, angelos, not from the new date. Linespeed was still silly also.

Re: XML Usage Meter/Data

Posted: Fri Aug 15, 2014 1:56 pm
by angelos
Dazzled wrote:It's was still running from the 1st of the month this morning, angelos, not from the new date. Linespeed was still silly also.
I've forwarded this to our Developers. Will leave it with them for now.

Re: XML Usage Meter/Data

Posted: Sat Aug 16, 2014 11:05 am
by Cogs
Dazzled wrote:It's was still running from the 1st of the month this morning, angelos, not from the new date. Linespeed was still silly also.
+1

There does not appear to be any changes at all to the XML data.

Re: XML Usage Meter/Data

Posted: Sat Aug 16, 2014 12:42 pm
by angelos
Cogs wrote:
Dazzled wrote:It's was still running from the 1st of the month this morning, angelos, not from the new date. Linespeed was still silly also.
+1

There does not appear to be any changes at all to the XML data.
As advised before this has been forwarded to our Developers.

Apologies for any inconvenience caused.

Re: XML Usage Meter/Data

Posted: Tue Aug 19, 2014 12:56 pm
by Cugel
Be nice if this could get fixed.

Re: XML Usage Meter/Data

Posted: Tue Aug 19, 2014 2:40 pm
by ShaminG
Cugel wrote:Be nice if this could get fixed.
Our development team is working on a fix ASAP. Apologies for any inconvenience caused.