Usasge meter no longer working

Queries, errors or glitches regarding Member facilities
gstark
Posts: 128
Joined: Sun Jan 18, 2004 8:45 am
Location: Beautiful downtown Bondi.

Usasge meter no longer working

Post by gstark » Tue Mar 14, 2017 6:30 am

Just in the last few days my usage meter - the Exetel Mini Usage Meter - has not been updating.

It's displaying a message saying that the user name/password is invalid, although nothing has changed at this end.

James
Exetel Staff
Posts: 1957
Joined: Mon May 09, 2005 10:27 pm

Re: Usasge meter no longer working

Post by James » Tue Mar 14, 2017 6:59 am

Is that a third party program?

User avatar
Dazzled
Volunteer Site Admin
Posts: 5997
Joined: Mon Nov 13, 2006 1:16 pm
Location: Sydney

Re: Usasge meter no longer working

Post by Dazzled » Tue Mar 14, 2017 8:32 am

My script doesn't either James. The XML data URL https://www.exetel.com.au/members/usage ... R,PASSWORD returns "error=Incorrect User/Pass"

A direct terminal connection to the server, with the certificate unchecked, produces the same message.

gstark
Posts: 128
Joined: Sun Jan 18, 2004 8:45 am
Location: Beautiful downtown Bondi.

Re: Usasge meter no longer working

Post by gstark » Tue Mar 14, 2017 1:58 pm

James wrote:Is that a third party program?
Hi James,

Thanks for the prompt response. Yes. It's this one, which has been working fine for years.

http://home.exetel.com.au/amurgshere/mxtlusage.phtml

The message that's being returned is exactly the same message that Dazzled reported: 'R,PASSWORD returns "error=Incorrect User/Pass"'

User avatar
Dazzled
Volunteer Site Admin
Posts: 5997
Joined: Mon Nov 13, 2006 1:16 pm
Location: Sydney

Re: Usasge meter no longer working

Post by Dazzled » Tue Mar 14, 2017 2:24 pm

Mine is the simple script published in this forum, with a GUI attached. The XML feed is no longer accepting connections.

User avatar
KavindaS
Forum Admin
Posts: 2012
Joined: Wed Dec 23, 2009 3:59 pm
Location: Sydney

Re: Usasge meter no longer working

Post by KavindaS » Tue Mar 14, 2017 2:40 pm

gstark wrote:Just in the last few days my usage meter - the Exetel Mini Usage Meter - has not been updating.

It's displaying a message saying that the user name/password is invalid, although nothing has changed at this end.
Can you check and tell me if the My Exetel https://www.exetel.com.au/my_exetel login is working to you with your current credentials?

User avatar
KavindaS
Forum Admin
Posts: 2012
Joined: Wed Dec 23, 2009 3:59 pm
Location: Sydney

Re: Usasge meter no longer working

Post by KavindaS » Tue Mar 14, 2017 2:40 pm

Dazzled wrote:Mine is the simple script published in this forum, with a GUI attached. The XML feed is no longer accepting connections.
Hi Dazzled,

Can you check the same and tell me if https://www.exetel.com.au/my_exetel is working to you or not?

gstark
Posts: 128
Joined: Sun Jan 18, 2004 8:45 am
Location: Beautiful downtown Bondi.

Re: Usasge meter no longer working

Post by gstark » Tue Mar 14, 2017 4:58 pm

KavindaS wrote:Can you check and tell me if the My Exetel https://www.exetel.com.au/my_exetel login is working to you with your current credentials?
Yes it is.

User avatar
Dazzled
Volunteer Site Admin
Posts: 5997
Joined: Mon Nov 13, 2006 1:16 pm
Location: Sydney

Re: Usasge meter no longer working

Post by Dazzled » Tue Mar 14, 2017 5:06 pm

My Exetel login works as usual. It's just the XML server.

User avatar
KavindaS
Forum Admin
Posts: 2012
Joined: Wed Dec 23, 2009 3:59 pm
Location: Sydney

Re: Usasge meter no longer working

Post by KavindaS » Tue Mar 14, 2017 10:24 pm

Since no issues with the normal member logins, I have escalated this with the Developing team and I will update both of you, when they have looked in to this.

gstark
Posts: 128
Joined: Sun Jan 18, 2004 8:45 am
Location: Beautiful downtown Bondi.

Re: Usasge meter no longer working

Post by gstark » Wed Mar 15, 2017 7:18 am

Thank you.

gstark
Posts: 128
Joined: Sun Jan 18, 2004 8:45 am
Location: Beautiful downtown Bondi.

Re: Usasge meter no longer working

Post by gstark » Fri Mar 17, 2017 8:21 am

Any progress on this matter please?

User avatar
KavindaS
Forum Admin
Posts: 2012
Joined: Wed Dec 23, 2009 3:59 pm
Location: Sydney

Re: Usasge meter no longer working

Post by KavindaS » Fri Mar 17, 2017 12:52 pm

gstark wrote:Any progress on this matter please?
It has been escalated internally with the Management. Waiting on their response. I will update once I have received their feedback.

James
Exetel Staff
Posts: 1957
Joined: Mon May 09, 2005 10:27 pm

Re: Usasge meter no longer working

Post by James » Fri Mar 17, 2017 9:57 pm

Our developers have suspended the XML feed,

"Sending username/password over GET request, even it uses https is not secured
They use Member Facilities password with third party app. App owner can easily steel the password password and login to Member facility."

If you need to access your usage, please log onto our website.

User avatar
Dazzled
Volunteer Site Admin
Posts: 5997
Joined: Mon Nov 13, 2006 1:16 pm
Location: Sydney

Re: Usasge meter no longer working

Post by Dazzled » Sat Mar 18, 2017 8:58 am

James, as you will remember, the website code has a long history of difficulties with this sort of thing, and scraping is not something to encourage. An SSL connection to the XML feed instead of simple GET or POST would do the job without dispute.

The best meters are all local scripts. There isn't an app owner.

Post Reply