Wrong index page on webspace

Web hosting, FTP/database access, mirror services and hosted blogs
Post Reply
jrock
Posts: 2
Joined: Tue May 25, 2010 5:19 pm
Location: Lennox Head

Wrong index page on webspace

Post by jrock » Wed May 26, 2010 4:34 pm

The Wrong Index page is opening on my web site though the new one appears to be on the server in the right location.

I updated my website a couple of days ago. All updated files except the Index page open properly. The old deleted Index page opens though the only Index page showing on the server is the new one (I downloaded the Index page visible on the server to confirm that it was the right one). When I try to refresh from the FTP software nothing changes. When I try to refresh from my web browsers I get a “Forbidden” message saying I don’t have permission to access my web site’s index page. Any suggestions would be gratefully received.

Gidget
Volunteer Site Admin
Posts: 1813
Joined: Wed Jan 28, 2004 4:33 am
Location: Sydney

Re: Wrong index page on webspace

Post by Gidget » Wed May 26, 2010 5:22 pm

Hi

I split your post off to a new thread in a more appropriate Forum - I assume you are referring to the free webspace that Exetel provides (if not, please let me know).

Your actual page name for your index page might be the issue here. Page names are case sensitive. This means, for example, that index.html is not equal to Index.html is not equal to INDEX.html, and so on.

If this isn't the problem, please PM me your webspace name and I'll ask SysAdmin to have a look at it.

Gidget
Log a fault ticket here
or call Exetel VOIP numbers (02) 8030 1000 or 1300 788 141 (log faults 24x7)
Exetel Support Portal

Dazzled
Volunteer Site Admin
Posts: 6003
Joined: Mon Nov 13, 2006 1:16 pm
Location: Sydney

Re: Wrong index page on webspace

Post by Dazzled » Wed May 26, 2010 6:00 pm

I think Gidget is spot on. The file must be spelled index.html for the default setting of Apache. I am guessing you use Windows, which doesn't distinguish case in file names, unlike the Linux web server. If necessary use your ftp client to change the file name on the server.

Tim K

Re: Wrong index page on webspace

Post by Tim K » Thu May 27, 2010 11:00 am

Dazzled wrote:If necessary use your ftp client to change the file name on the server.

I'd also extend this to changing it on your local machine as well, if you find this is the problem.

Dazzled's suggestion will - if this is the problem - obviously cause your website to start working. However, if you ever go back to update it, you'll just end up confusing yourself if you don't do it on your computer as well.

jrock
Posts: 2
Joined: Tue May 25, 2010 5:19 pm
Location: Lennox Head

Re: Wrong index page on webspace

Post by jrock » Thu May 27, 2010 9:22 pm

Thanks for the comments folks. Doesn’t seem to be a case issue. The file on my site on Exetel’s server is “index.html”. I tried deleting it again, refreshed, deleted the original file name on my computer and typed it again in lower case, then transferred it to the site. No change. Where is the old index file coming from? Its not there on my site. It must be stored somewhere else where it is being accessed? Or it is invisible and for some reason is preferred.
jrock

ForumAdmin
Posts: 3663
Joined: Sun Jan 04, 2004 2:31 pm
Location: Sydney

Re: Wrong index page on webspace

Post by ForumAdmin » Thu May 27, 2010 9:32 pm

I've asked the appropriate sysadmin to respond.

Dazzled
Volunteer Site Admin
Posts: 6003
Joined: Mon Nov 13, 2006 1:16 pm
Location: Sydney

Re: Wrong index page on webspace

Post by Dazzled » Thu May 27, 2010 9:34 pm

While you wait for sysadmin, check the spelling again, inside the logged-in ftp client (not on a Windows file system), and check also that it is in the root directory of your space. Unlike Windows, Unixes will let you put an inadvertent full stop on it, to make a valid, but useless, file name.

SysAdmin

Re: Wrong index page on webspace

Post by SysAdmin » Fri May 28, 2010 9:17 am

jrock wrote:Thanks for the comments folks. Doesn’t seem to be a case issue. The file on my site on Exetel’s server is “index.html”. I tried deleting it again, refreshed, deleted the original file name on my computer and typed it again in lower case, then transferred it to the site. No change. Where is the old index file coming from? Its not there on my site. It must be stored somewhere else where it is being accessed? Or it is invisible and for some reason is preferred.
jrock
From what I just saw it was a file permission issue. You had 640 (or rw-r-----) whereas you should've had
604 (rw----r--).

I fixed that and I can see a guy surfing on the index page. The text on the page I got matches the bits I checked in the file.

Andrew

Post Reply