Page 1 of 2

exetel settings on Android

Posted: Fri Jan 29, 2010 9:54 am
by jjjasont
Has anyone successfully setup hspa broadband on android?

This is my settings and it doesn't work

APN - exetel1
Proxy - <not set>
Port - <not set>
Username - <exetel username>
Password - <exetel pwd>
Server - <not set>
MMSC - null
MMS Proxy - <not set>
MMS Port - <not set>
MCC - 505
MNC - 02
Authentication type - PAP or CHAP
APN Type - default

Re: exetel settings on Android

Posted: Fri Jan 29, 2010 2:13 pm
by Need2No
jjjasont wrote:Has anyone successfully setup hspa broadband on android?

This is my settings and it doesn't work

Username - <exetel username>
Password - <exetel pwd>
On my Nokia, I don't need a username or password.

Regards

Re: exetel settings on Android

Posted: Fri Jan 29, 2010 5:44 pm
by Gidget
jjjasont wrote:Has anyone successfully setup hspa broadband on android?

This is my settings and it doesn't work

APN - exetel1
Proxy - <not set>
Port - <not set>
Username - <exetel username>
Password - <exetel pwd>
Server - <not set>
MMSC - null
MMS Proxy - <not set>
MMS Port - <not set>
MCC - 505
MNC - 02
Authentication type - PAP or CHAP
APN Type - default
For HSPA you should only require to set the APN to "exetel1" and leave other settings as default - you definitely don't need a username and password, the ones you are using are probably those for your User Facilities.

Gidget

Re: exetel settings on Android

Posted: Sun Jan 31, 2010 8:03 pm
by tin
In theory it should work with those settings (minus the username/password).

It doesn't work for me either, but I'm not using a properly released Adnroid device. I've got a Touch Pro running a community port, so there's some major stuff not working right anyway. My failure could be something not ported completely yet, so I don't consider it good proof.

Re: exetel settings on Android

Posted: Fri Feb 05, 2010 4:41 pm
by jjjasont
Thanks everyone who has replied

I'm 100% sure the following configuration will work on android because I managed to use gprs for browser/google sync/google map for one and only one time. When the phone rebooted, the above application does not work again:-(...

I think the reason for not being able to browse the internet, sync your google account, access google map..... etc is that android somehow does not use gprs as its default data connection. (Even when wifi is switched off)

The reason why I'm 100% sure it works because Sipdroid, a program to make and receive called via VOIP, is still functioning by specifying GPRS as the data connection in the program.

fyi, I'm using HTC diamond with android ported.


Name - exetel1
APN - exetel1
Proxy - <not set>
Port - <not set>
Username - <not set>
Password - <not set>
Server - <not set>
MMSC - <not set>
MMS Proxy - <not set>
MMS Port - <not set>
MCC - 505
MNC - 02
Authentication type - PAP or CHAP
APN Type - default

Re: exetel settings on Android

Posted: Tue Feb 09, 2010 1:57 pm
by tin
Tried again on mine - still no go for me either.
It looks like data is trying to go out on mine. There's an icon saying "3G" and an up arrow flashes every now and then when you ask it to get data (syncing, maps, etc)... but the down arrow never shows anything.

I'm not sure if I've got an IP on mine though. It may never even get to that stage.

Just also did some reading back over the topic at xda-developers and it seems Vodafone Netherlands users are also seeing the same thing. Looks connected but never gets any data.

Re: exetel settings on Android

Posted: Wed Feb 10, 2010 12:13 pm
by jjjasont
Ya me too. I can't figure it out to work again. :-(
I wish I could recall what I did last time.

Anyway, Sipdroid is still working under GPRS. Have no clue why it works.

You can give Sipdroid a try if you have a VOIP account. (Connect you phone with wifi and sipdroid can be found in the "Market".)

Re: exetel settings on Android

Posted: Tue Feb 16, 2010 1:56 pm
by matboislim
Mine works with these settings:

APN - exetel1
Proxy - <not set>
Port - <not set>
Username - <not set>
Password - <not set>
Server - <not set>
MMSC - null
MMS Proxy - <not set>
MMS Port - <not set>
MCC - 505
MNC - 02
Authentication type - <not set>
APN Type - <not set>

Basically, I created a new Access Point called exetel1 and left all the values as default.
Also sipagent works great with voip over 3G.

Re: exetel settings on Android

Posted: Sun Jun 20, 2010 5:04 pm
by tin
OK, thread digging a little here, but I found the problem... It's simply DNS failing to be set correctly.
Under WinMob, I get correct DNS. Under this build of Android, I get 10.11.12.13 and 10.11.12.14... But oddly, in WinMob, these addresses show up too, but as WINS servers (surely Exetel isn't sending these, are they?).

So the fix? Needs a terminal, but running the following fixes it for me (obviously a terminal is needed)...
setprop net.dns1 220.233.0.3
setprop net.dns2 220.233.0.4
setprop net.gprs.dns1 220.233.0.3
setprop net.gprs.dns1 220.233.0.4

Now, I'm not entirely sure how to make this a permanent change, but it's definitely got mine working at the moment.

Re: exetel settings on Android

Posted: Tue Aug 17, 2010 12:17 am
by Old Flame
I followed The instructions in the members area as follows in relation to MOIP for Android:

There are 3 steps to this process:

Ensure you have an Exetel VoIP account (if not click here)
Purchase and download the Sip agent App
Configure the settings with your Exetel VoIP account
Purchase and Download the Sip agent App

Go to the android Store by clicking “Market Place” on the Android Phone
Search for “Sip agent”
Click Download to install on your phone
Enter domain server: 58.96.1.2
Enter your VoIP Number and the VoIP Password
Click Register
The application should then register and allow you to make/receive calls.

When I search for Sip agent, it's not there, the closest is an app called voIP Sip agent for 10 Pounds UK (is that it)? Thinking maybe there is an Exetel MOIP app there now I searched on Exetel and there is only an Exetel WebSMS app :dunno:

Re: exetel settings on Android

Posted: Fri Aug 27, 2010 12:50 pm
by jjjasont
Old Flame

I strongly recommend you to give Sipdroid a try.
http://sipdroid.org/

It is the god father of native SIP/VOIP on Android.
It has been cloned into several different VOIP application on Android.



Tin.

Thanks, I'll give that a try and post the result later.

Re: exetel settings on Android

Posted: Fri Aug 27, 2010 8:17 pm
by Old Flame
jjjasont wrote:Old Flame

I strongly recommend you to give Sipdroid a try.
http://sipdroid.org/

It is the god father of native SIP/VOIP on Android.
It has been cloned into several different VOIP application on Android.



Tin.

Thanks, I'll give that a try and post the result later.
Thanks,
Took too long to find something that worked so I went on an Optus Post paid plan, but thanks anyways :wink: :D

Re: exetel settings on Android

Posted: Fri Nov 12, 2010 8:54 am
by guyclk
My Provision email from Exetel had the

APN - internet

Just like it was when I was an Optus customer.

APN- exetel1 did and dose not work.

Re: exetel settings on Android

Posted: Fri Nov 12, 2010 9:23 am
by jokiin
guyclk wrote:My Provision email from Exetel had the

APN - internet

Just like it was when I was an Optus customer.

APN- exetel1 did and dose not work.
exetel1 is used on the HSPA plans, the CAP plans uses internet even though they are both Optus based services the details are different for each

Re: exetel settings on Android

Posted: Tue Nov 23, 2010 12:25 am
by Cherryred
matboislim wrote:Mine works with these settings:

APN - exetel1
Proxy - <not set>
Port - <not set>
Username - <not set>
Password - <not set>
Server - <not set>
MMSC - null
MMS Proxy - <not set>
MMS Port - <not set>
MCC - 505
MNC - 02
Authentication type - <not set>
APN Type - <not set>
Has jjjasont managed to solve his problem? I have the exact same issue - got a HTC Magic running Android, created a new APN called 'exetel1' as per the instructions and left everything else to auto-default as above, and three weeks later I still have nothing. It also took nearly 3 days to port, so I'm really not happy right now.