Page 3 of 3

Re: Asus eeePC 900 linux and E160E modem

Posted: Mon Dec 24, 2012 3:39 pm
by brumer
Well I just thought I'd let you know I tried a few things.
Firstly I had a spare 120gig HD here so after I downloaded the Linux Mint iso & burnt it to DVD, then popped in the HD & installed Mint to it. All good so far.
Mint runs so slow on this computer that I nearly gave it away at this stage.
Wired network to ADSL modem works.
USB 3g Exetel works.
Browsing works etc, etc.
Installed the "opencpn" program & it fixed a few extra's.
Couldn't find the executable in list of apps. Rebooted & it was there.
Clicked to start it but it started with the "don't use this ONLY for navigation bla bla bla.......
......... and then nothing................
Whilst doing this I did not have the USB 3g or the USB GPS plugged in.
No error, no indication it was EVER going to happen.

There are a HEAP! of updates it wants to download & install. Should I do that?
Incidently I do have, & have had for some time, opencpn running the Windows version on XP & it is much faster I think.
Just thought I'd stretch the brain!!

Re: Asus eeePC 900 linux and E160E modem

Posted: Mon Dec 24, 2012 4:38 pm
by Dazzled
If you are running Mint off the bootable DVD it is extra slow. This is because a DVD drive is no match for a hard drive at reading data. As long as you run the live DVD it won't involve the hard disc so any Windows, user data, etc present is quite safe. It's a useful hardware test package though, because the rest of your computer is active. It can also be used to repair many forms of file damage, but that's for another day. You have the system working, and that's all good.

If you have a suitable spare machine and actually install Mint (press the install icon on the desktop) you will get speed. Calculations on any PC depend on the CPU model, but Linux memory and file management are much more efficient than Windows, and fortunately it is less dependent on you-beaut hardware or large amounts of RAM, so it really goes.

(Advanced physics and mathematical work is always done on Linux boxes for this reason. Surprisingly, with modest hardware - I know of a fast high energy physics simulation with a low speed 4 core CPU, but only 2 GB of RAM, an old 80 GB hard drive, and an old 13 inch monitor - any attempt to run it on a new high-spec Windows box chokes up).

When you physically install Mint it will ask to go online to update itself. This is important - Linux systems self security update, and will usually change to new kernels as they come along. Since you get some very big packages like Libre Office with the installation, expect a large update. The repository mirrors are all secure connections.

I'm no expert on opencpn (I only saw it yesterday), but I suspect it needs the GPS system to be running. If you can find System->Administration->System Monitor you can see what's running at any time.

For what it's worth, I have installed Mint on the machines of several retirees who had proved themselves unable to manage Windows, or avoid malware. None of them would now use anything else. Anyone who tells you Linux systems are only for advanced users is usually a salesman for something expensive.

Last, and I hesitate to tell a newbie: If you start opencpn by typing its commands from a terminal, you will get all the error messages and diagnostics, possibly together with a host of false errors, as some programmers test for hardware by creating errors and noting the result. Warning: this can look scary.

Re: Asus eeePC 900 linux and E160E modem

Posted: Mon Dec 24, 2012 7:24 pm
by Dazzled
Postscript: A preliminary opencpn requirement for Ubuntu family systems (ie Mint): In a terminal:
sudo apt-get install libwxgtk2.8-0 libwxbase2.8-0 wx-common libglu1-mesa libgl1-mesa-glx zlib1g bzip2 gpsd gpsd-clients xcalib

This is to ensure the dependencies of opencpn are met. If they are already present it won't matter. The application itself is installed just by clicking on the deb file in the file manager.
click on the Toolbox icon and configure your GPS source, chart directories, and other settings.
If there is a problem connecting the GPS to a physical port, such as /dev/ttyS0, make sure that you, as a user, belongs to the "dialout" group. If you're not in "dialout", add yourself with "sudo usermod -a -G dialout $USER"
(another typed terminal command)

This user has it nailed: ... 91302.html

Re: Asus eeePC 900 linux and E160E modem

Posted: Mon Dec 24, 2012 11:06 pm
by brumer
Thankyou for your help.
My previous post did say I had it on the 120gig HD. (I removed completely the other HD with XP on it)
I think the slowness is more to do with the video card driver deficiency....... apparently a common problem?
It's rather like Windows before you install the correct video card driver.
I will run the updates & then run the dependencies.
Then I'll plug in the USB GPS & see what happens.
Might not be tomorrow....... apparently something else is on?
Merry Christmas Dazzle & anyone else reading this.

EDIT: I fixed it by stopping the Huawei modem from being a storage device & not pretend it's a CD drive.
Imortant to save the software off of it & then connect via Hyperterminal (XP etc) & issue ATE1 & then AT^U2DIAG=0
It now doesn't try to install & it is ONLY a modem. Connected straight away.
Thankyou Dazzled for your help. (now where is Honalulu? Hey! No Exetel out here? lol)