HELP PLEASE: Sharing files on home wi-fi network

Wired and wireless home networking
Post Reply
bigkev81
Posts: 27
Joined: Mon Nov 24, 2008 9:43 pm
Location: Holsworthy

HELP PLEASE: Sharing files on home wi-fi network

Post by bigkev81 » Sat Nov 29, 2008 6:06 pm

Hi there,

I am needing assistance in sharing my files over my wifi network at home. Heres a bit of background:

I was previously connect to Bigpond Cable Extreme through a Motorola SBG900 wifi router.
My main PC is running windows Vista and was connected to the router via the RJ45 network cable.
I also have a MacBookPro and another desktop PC which both connect to the internet through wifi.
I was able to access my shared folders through my wifi network which made it easy to share files with my brother and mum throughout the house.

After getting fed up with Bigponds high prices ($129.95pm for 60GB, watta joke LOL) I made the switch to exetel.
I have the NB6PLUS4W now which is also connected to my PC through the RJ45 network cable as before, and the others connect to the internet via wifi.

The only issue is sharing my folders. All computers are still in the same workgroup and nothing has changed aside from the routers and the IP addresses.
Correct me if I'm wrong but as long as the other computers are connected to the same wifi network I should still be able to access my shared folders right?

All that has really changed is the router and IP Addresses which I have adjusted accordingly. But for some unknown reason, I cant for the life of me, access my shared files over the wifi network with this router.

Its driving me insane and I am going through tons of blank dvds copying my files to my laptop.
I do alot of work from home with rather large files (a few gigs) and quite frequently swap between my PC and my laptop depending on where in the house I am ie. Laptop when I wanna watch something on TV or when my mum/bro want to use my pc.

Is there a setting for my router that i need to enable to get this working? What am I doing wrong.

Sorry for the long winded post but I wanted to include as much as I can to hopefully get this resolved ASAP.
Any info would be greatly appreciated and I thank you all in advance.

Kind Regards
:)
Kev

CoreyPlover
Volunteer Site Admin
Posts: 5922
Joined: Sat Nov 04, 2006 2:24 pm
Location: Melbourne, VIC

Re: HELP PLEASE: Sharing files on home wi-fi network

Post by CoreyPlover » Sat Nov 29, 2008 11:43 pm

bigkev81 wrote:The only issue is sharing my folders. All computers are still in the same workgroup and nothing has changed aside from the routers and the IP addresses.
Correct me if I'm wrong but as long as the other computers are connected to the same wifi network I should still be able to access my shared folders right?
This is correct. With the instructions below, I'm only familiar with XP machines. Hopefully the Vista configuration will be similar enough for you.

First, ensure your machines are all on the same subnet. In the Vista machine, you can type IPCONFIG in a Command Prompt window. On the Mac, you can type "IFCONFIG" or "IFCONFIG -a" in a Terminal window, or alternatively use the System Preferences, Network tab. You should see a subnet or 255.255.255.0 and the IP addresses of each machine should have the same first three numbers and a different last number.

Second, ensure File Sharing is enabled. On an XP machine, this would be under Settings, Network Connections, right-click Local Area Connection, Properties and there should be an item for "File and Printer Sharing for Microsoft Networks".

Third, ensure a directory is shared correctly by right-clicking one in Windows Explorer, Sharing & Security, Share this folder. Under Permissions, make sure Everyone has Read access. Also, you might need to check the Security tab, and also add "Everyone" to the 'Group or user names'.

Fourth, ensure your firewall is not screwing things up. Temporarily uninstall any third party firewall software like ZoneAlarm (these are useless anyway, but that is a topic for another day) and also check under Settings, Control Panel, Windows Firewall. Either select "Off" for now, or "On, with exceptions" and ensure that File and Print sharing in the Exceptions tab is selected

Fifth, sometimes you need to specifically enter the computers name instead of rely on it appearing in a list like "My Network Places". On the second PC, you can right-click "My Network Places" and choose "Search for Computers". Entering the first PC by name often makes it appear and allow browsing of its shared directories.

Note that these instructions only allow you to connect to a remote PC's shared directory and get files. If you wish to place files onto this shared directory, you either need to use matching logins on each machine, or set the Sharing and Security permissions for the user name in step 3 above, or you need to allow the group "Everyone" to have Write or Full permissions.

jonzei
Posts: 11
Joined: Wed Aug 29, 2007 5:37 pm
Location: Melbourne

Re: HELP PLEASE: Sharing files on home wi-fi network

Post by jonzei » Tue Dec 02, 2008 3:38 pm

It's most likely the Firewall picked up a change in IP and blocked connection attempts.

You can do a manual check by opening a command prompt and typing:

net use \\<remoteComputerName or IPaddress>\shareName /user:<userName>
where the <userName> is a valid account on the remote PC
If you get a message that connection was successful then you should be able to see the share drive in Windows Explorer, you may also wish to map it for easy access (Right Click on remote share then 'Map Network Drive ...' and follow prompts)

If you wish to enable sharing without being asked for credentials then do the following in WinXP (not sure for Vista, sry):

goto Administrative Tools | Local Security Policy | Local Policies | Security Options -> then change the following
Network access: Do not allow anonymous enumeration of SAM accounts: Enabled
Network access: Allow anonymous SID/Name translation: Enabled

Network access: Sharing and security model for local accounts: Guest only - local users authenticate as Guest
MUST REBOOT before settings become available

After that you should be able to share without the need for a remote user account.

Hope it helps

bigkev81
Posts: 27
Joined: Mon Nov 24, 2008 9:43 pm
Location: Holsworthy

Re: HELP PLEASE: Sharing files on home wi-fi network

Post by bigkev81 » Fri Dec 05, 2008 12:01 am

jonzei wrote:It's most likely the Firewall picked up a change in IP and blocked connection attempts.

You can do a manual check by opening a command prompt and typing:

net use \\<remoteComputerName or IPaddress>\shareName /user:<userName>
where the <userName> is a valid account on the remote PC
If you get a message that connection was successful then you should be able to see the share drive in Windows Explorer, you may also wish to map it for easy access (Right Click on remote share then 'Map Network Drive ...' and follow prompts)

If you wish to enable sharing without being asked for credentials then do the following in WinXP (not sure for Vista, sry):

goto Administrative Tools | Local Security Policy | Local Policies | Security Options -> then change the following
Network access: Do not allow anonymous enumeration of SAM accounts: Enabled
Network access: Allow anonymous SID/Name translation: Enabled

Network access: Sharing and security model for local accounts: Guest only - local users authenticate as Guest
MUST REBOOT before settings become available

After that you should be able to share without the need for a remote user account.

Hope it helps
jonzei, you are a legend!!!! :D

With the new ip addresses i forgot i had to update the firewall in norton.
After changing my ip range from 192.168.0.* to 192.168.1.* everything resumed back to the way it was.
I'm actually quite embarrased as the solution was quite easy.

Thanks a bundle :D
Cheers
Kev

Post Reply