Page 1 of 1

Wireless modem connects, but only upload, no download.

Posted: Mon Nov 17, 2008 10:10 pm
by dov
The first few times I used the modem (E169) it was great, but then it started connecting badly to the network about 9 times out of 10. I would get upload, but no download. It has done this on both 3g and gprs connections, in various locations and on two computers (one running Ubuntu Linux, the other XP). Has anyone else had this problem?

dov

Re: Wireless modem connects, but only upload, no download.

Posted: Mon Nov 17, 2008 10:26 pm
by Dazzled
I don't know whether it is playing up or not, but if you are running Hardy, do you know about:
NetworkManager 0.7 - http://launchpad.net/~network-manager/+archive
usb_modeswitch - http://www.greenhughes.com/content/huaw ... g-easy-way (for EEEs)
These will integrate the modem nicely. I haven't played with Intrepid yet, so these might now be there.

Re: Wireless modem connects, but only upload, no download.

Posted: Tue Nov 18, 2008 9:37 am
by dov
I've been using Intrepid since Alpha 5. Not sure if it has been a DNS issue, as I was still using the Optus DNS settings that were loaded automatically. Have changed these settings to 220.233.0.3, 220.233.0.4, which I found in one post of this forum. Can't remember which one. Waiting to see if that fixes the issue.

As I said in my first post, the problem occurred in XP as well as Linux. I checked it on a mate's computer.

Re: Wireless modem connects, but only upload, no download.

Posted: Tue Nov 18, 2008 7:28 pm
by dov
Changing the DNS settings seems to have fixed things. One of the pre-loaded DNS addresses even looked like a LAN address (192...)! Perhaps the Exetel DNS addresses should be included in the setup guides?

dov