Set up on Nokia N95

HSPA setup and configuration (for wireless networking, please use the 'Networking issue' forum)
User avatar
Gidget
Volunteer Site Admin
Posts: 1808
Joined: Wed Jan 28, 2004 4:33 am
Location: Sydney

Re: Set up on Nokia N95

Post by Gidget » Sat Jan 10, 2009 12:58 pm

Hi Morphed

Can you post the SIP details you currently have set up in your N95 (obscure your personal details) and I'll try and give you a hand with it.

Gidget
Log a fault ticket here
or call Exetel VOIP numbers (02) 8030 1000 or 1300 788 141 (log faults 24x7)
Exetel Support Portal

Morphed
Posts: 24
Joined: Mon Dec 01, 2008 6:02 pm
Location: Adelaide City

Re: Set up on Nokia N95

Post by Morphed » Sat Jan 10, 2009 1:26 pm

Thanks Gidget. I need to start at the basic. I am on a HSPA M1 HA plan. I can make standard cellular calls. I have downloaded fring successfully and can make a fring test call. I am having difficulty setting up a mobile voip.. When it comes to setting up SIP on my Nokia N95 it asks for a SIP profile. I can select default or a new. Can you suggest what I enter here. I presume it is exetel ? I think it is best to do one step at a time. I hope you have the time.

User avatar
Gidget
Volunteer Site Admin
Posts: 1808
Joined: Wed Jan 28, 2004 4:33 am
Location: Sydney

Re: Set up on Nokia N95

Post by Gidget » Sat Jan 10, 2009 2:36 pm

No problem :D

I presume you have already set up an Exetel access point, but if you haven't then do this first.

To set up an Exetel access point (APN), go to Tools -> Settings -> Connection -> Destinations -> Internet
Then click Options -> New access point
Then enter these settings:
Connection name: exetel1
Data bearer: Packet data
Access point name: exetel1
User name: None
Prompt password: no
Password: leave blank
Authentication: Secure
Homepage: none
Use access point: select "After confirmation" or "automatically", depending on your preference

If you have more than 1 internet access point, you should give priority to "exetel1" (I deleted the Optus access point on my N96 so I only have "exetel1" under "Internet").

To set up your SIP profile, hit "Back" until you are back on the "Connection" screen (Tools -> Settings -> Connection if you get lost). Scroll down to "Sip Settings" then hit "Options" and "New SIP profile", then enter these settings (I haven't yet looked up the N95 User Guide, so if any of these setting options are different to what is on your phone, then let me know and I'll look into it further):

Profile name: Exetel
Service profile: IETF
Default access point: exetel1
Public user name: sip:yourvoipnumber@58.96.1.2 (the N95 might automatically put the "sip:" here and later on, if it does and you end up with 2 "sip:" in these lines then just delete one of them)
Use compression: no
Registration: when needed
Use security: no

Under the "Proxy server" sub-menu, enter
Proxy server address: sip:58.96.1.2
Realm: 58.96.1.2
User name: yourvoipnumber
Password: yourvoippassword
Allow loose routing: Yes
Transport type: UDP
Port: 5060

Go back a level and under the "Registrar server" sub-menu, enter
Registrar server address: sip:58.96.1.2
Realm: 58.96.1.2
User name: yourvoipnumber
Password: yourvoippassword
Transport type: UDP
Port: 5060

Keep hitting "Back" or "Exit" until you get back to your standby screen.

Now, try to make an internet call.

I hope I haven't missed out any steps but if I have, or if anything isn't clear, just post back again.

Gidget
Log a fault ticket here
or call Exetel VOIP numbers (02) 8030 1000 or 1300 788 141 (log faults 24x7)
Exetel Support Portal

Morphed
Posts: 24
Joined: Mon Dec 01, 2008 6:02 pm
Location: Adelaide City

Re: Set up on Nokia N95

Post by Morphed » Sat Jan 10, 2009 4:05 pm

Thanks Gidget, i was all over the place with what had to go where. I feel as if i'm nearly there. After completing the registration the message come up on the Nokia Unable to save. Profiles in same realm must have same user name.In my SIP settings there is Exetel or Profile as a choice. I cannot delete either of these, so put all the detail in Exetel instead of Profile.Also in the Access point i don't have the option of Destinations. I have Bluetooth,USB,Access Points(I have exetel1 here but no other options to insert any further data.)Under APN controlthe message comes up connection restrictions inactiveWireless lan etc,etc. Is there any other option ? 

User avatar
Gidget
Volunteer Site Admin
Posts: 1808
Joined: Wed Jan 28, 2004 4:33 am
Location: Sydney

Re: Set up on Nokia N95

Post by Gidget » Sat Jan 10, 2009 4:15 pm

Hi Morphed

Give me a few minutes to check out the N95 manual and I'll come back to you - it seems there are some minor menu differences between the N95 and the N96 so I'll have to read up on it a bit.

Gidget
Log a fault ticket here
or call Exetel VOIP numbers (02) 8030 1000 or 1300 788 141 (log faults 24x7)
Exetel Support Portal

Morphed
Posts: 24
Joined: Mon Dec 01, 2008 6:02 pm
Location: Adelaide City

Re: Set up on Nokia N95

Post by Morphed » Sat Jan 10, 2009 4:31 pm

No probs Gidget, thanks so much for your help

User avatar
Gidget
Volunteer Site Admin
Posts: 1808
Joined: Wed Jan 28, 2004 4:33 am
Location: Sydney

Re: Set up on Nokia N95

Post by Gidget » Sat Jan 10, 2009 4:40 pm

Hi Morphed

The manual wasn't much use - it didn't tell me anything new :roll:

I think your settings should be okay but I also think you might have a typo in there somewhere - the error message "Unable to save. Profiles in same realm must have same user name." indicates that you have a mismatch somewhere. Particularly check your "Proxy Server" and "Registrar Server" settings to make sure they appear exactly as in my earlier post. Making sure the "sip:" appears in the relevant spots (Public user name:, Proxy server address: and Registrar server address:) is also very important.

If you still have no joy, I think you'll need to post exactly what you have entered and where, so we can go through it.

Gidget
Log a fault ticket here
or call Exetel VOIP numbers (02) 8030 1000 or 1300 788 141 (log faults 24x7)
Exetel Support Portal

Morphed
Posts: 24
Joined: Mon Dec 01, 2008 6:02 pm
Location: Adelaide City

Re: Set up on Nokia N95

Post by Morphed » Sat Jan 10, 2009 6:34 pm

Hi Gidget, Have triple checked so here goes all the details.
Tools-settings-connection-access points
exetel1

select

Connection name: red asterix exetel1
Data bearer:Packet data
Access point name:exetel1
User name:none
Prompt password:No
Password:blank
Authentication:Secure
Homepage:none

I am unable to locate at this stage via the menu - Use access point: After confirmation or automatically
my options/submenu only gives change,advanced settings,help or exit.



Tools-Settings-Connection-SIP settings
Exetel
Not registered

Select

Profile name: Exetel
Service Profile: IETF
Default access point: exetel1
Public user name:sip:087200xxxx@58.96.1.2
Use compression:no
Registration:When needed
Use security:No
Proxy Server Address:sip:58.96.1.2
Realm:58.96.1.2
User name:087200xxxx
Password:as supplied and printed from email
Allow loose routing:Yes
Transport type:UDP
Port:5060

Where am i making my mistake do you think?
Thanks once again for your help

User avatar
Gidget
Volunteer Site Admin
Posts: 1808
Joined: Wed Jan 28, 2004 4:33 am
Location: Sydney

Re: Set up on Nokia N95

Post by Gidget » Sat Jan 10, 2009 7:02 pm

Hi Morphed
Morphed wrote:I am unable to locate at this stage via the menu - Use access point: After confirmation or automatically
my options/submenu only gives change,advanced settings,help or exit.
It looks like the "Use access point" option might be an extra option on the N96. I think from your earlier post that you only have one access point set up anyway, so I wouldn't worry about it at the moment. If you go to "Advanced settings", they should probably look like this:

Network type: IPv4
Phone IP address: Automatic
DNS addresses: Automatic
Proxy server address: None
Proxy port number: 0

If your advanced settings are different to these, can you please post them here.

Re your SIP settings
Profile name: Exetel
Service Profile: IETF
Default access point: exetel1
Public user name:sip:087200xxxx@58.96.1.2
Use compression:no
Registration:When needed
Use security:No
Proxy Server Address:sip:58.96.1.2
Realm:58.96.1.2
User name:087200xxxx
Password:as supplied and printed from email
Allow loose routing:Yes
Transport type:UDP
Port:5060
Have you also set up the Registrar Server in the SIP settings as per my earlier post (because you didn't post those settings just now):
Under the "Registrar server" sub-menu, enter
Registrar server address: sip:58.96.1.2
Realm: 58.96.1.2
User name: yourvoipnumber
Password: yourvoippassword
Transport type: UDP
Port: 5060
Gidget

Edit - Also, I have assumed that you are trying to set up the VOIP with your phone connecting directly to the internet (via APN exetel1) rather than connecting via your WLAN (it's just that you wrote "Connection name: red asterix exetel1" in your last post, and I suddenly thought that you might be trying to make a WLAN / WiFi connection).
Log a fault ticket here
or call Exetel VOIP numbers (02) 8030 1000 or 1300 788 141 (log faults 24x7)
Exetel Support Portal

Morphed
Posts: 24
Joined: Mon Dec 01, 2008 6:02 pm
Location: Adelaide City

Re: Set up on Nokia N95

Post by Morphed » Sat Jan 10, 2009 7:27 pm

Hi Gidget,The advanced settings are as per your post so that's right.Have definitely set up the SIP register just as you detailed but still comes up with the same message.

Registrar server address:sip:58.96.1.2
Realm:58.96.1.2
User name:087200xxxx
Password:as supplied
Transport type:UDP
Port:5060

Its got me baffled!!
About to go out for tea.
Catch you soon

User avatar
Gidget
Volunteer Site Admin
Posts: 1808
Joined: Wed Jan 28, 2004 4:33 am
Location: Sydney

Re: Set up on Nokia N95

Post by Gidget » Sat Jan 10, 2009 8:56 pm

Hi Morphed

I must confess that I'm not an expert in these new-fangled contraptions but it looks like the native SIP client in your N95 doesn't want to play nice :D . I have read a few posts around the traps that the native client on Nokia mobiles (if you could use it you wouldn't need to use fring) can be a cantankerous little varmint :lol: For example, see these comments on Steve's blog.

But all is not lost, let's go to Plan B (at least until someone more knowledgeable than I comes along to work out what your issue is).

Plan B is to use fring. Since you've already done the hard part and installed it, and presumably entered your VOIP details during the installation process, all that remains is to make sure it uses your "exetel1" access point.

Start fring, then go to Options -> Settings -> Connectivity -> Access point group - this should say "exetel1".

If so, back out of that menu, pick a contact to call, then go to Options -> Call -> SIP call -> Select

That should be all there is to it (famous last words) :lol:

Let me know how this goes.

Gidget
Log a fault ticket here
or call Exetel VOIP numbers (02) 8030 1000 or 1300 788 141 (log faults 24x7)
Exetel Support Portal

samarium
Posts: 376
Joined: Thu Feb 02, 2006 12:17 am

Re: Set up on Nokia N95

Post by samarium » Sun Jan 11, 2009 3:04 am

Have you downloaded and installed the Nokia SIP Voip Settings application?, and used it to setup the SIP profile?

Morphed
Posts: 24
Joined: Mon Dec 01, 2008 6:02 pm
Location: Adelaide City

Re: Set up on Nokia N95

Post by Morphed » Sun Jan 11, 2009 12:49 pm

Went to the Nokia site , download sorftware tab, Configuration tool for advanced users. Is this what you are suggesting? I could not find  Nokia SIP Voip Settings application in the Nokia site even with a specialised search. Typing in Voip under there site brings up zero responses. Downloading the configuration tool also did not work properly but was unsure if this is what you are suggesting for me to do. Thanks.

Gidget, tried your suggestion on Fring and this is what happens.
Click on Fring icon.
Select access point
choice of search for WLAN
exetel1

Select exetel1 and the error comes up "Could not establishconnection to the network. Would you like to start automatic search.
Tests then gives the same rsponse back.
Hmmmnn.

User avatar
Gidget
Volunteer Site Admin
Posts: 1808
Joined: Wed Jan 28, 2004 4:33 am
Location: Sydney

Re: Set up on Nokia N95

Post by Gidget » Sun Jan 11, 2009 12:59 pm

Hi Morphed

I think you might have missed my edit last night at the bottom of this post where I suddenly realised that we might have been talking at cross purposes. You are trying to connect to your WLAN, and I was talking about connecting directly to the internet.

As a test, with fring, don't try to connect to your WLAN, connect to your "exetel1" access point (which is set up to connect to the internet) instead.

How does that go?

Gidget
Log a fault ticket here
or call Exetel VOIP numbers (02) 8030 1000 or 1300 788 141 (log faults 24x7)
Exetel Support Portal

User avatar
jokiin
Volunteer Site Admin
Posts: 2970
Joined: Mon Feb 02, 2004 10:23 pm
Location: Sydney

Re: Set up on Nokia N95

Post by jokiin » Sun Jan 11, 2009 2:58 pm

Morphed wrote:Went to the Nokia site , download sorftware tab, Configuration tool for advanced users. Is this what you are suggesting? I could not find  Nokia SIP Voip Settings application in the Nokia site even with a specialised search.

see this post http://forum.exetel.com.au/viewtopic.ph ... 66#p224666

Post Reply