Error 619 on Connection Attempt to Exetel Wireless BB

HSPA setup and configuration (for wireless networking, please use the 'Networking issue' forum)
Post Reply
mcalong
Posts: 1
Joined: Tue Dec 23, 2008 11:32 am
Location: Adelaide

Error 619 on Connection Attempt to Exetel Wireless BB

Post by mcalong » Tue Dec 23, 2008 5:26 pm

When first installing the Wireless Broadband software that self installs using an E169 modem the following issue was experienced on two installations using the very same modem. This post serves to provide any hints for other users that may experience the same issue, but the solution provided is what I used as a workaround, however may need to be confirmed by Exetel client software engineers.

Applies to: Wireless Broadband 11.002.03.25.74 (Connection Software)
Exetel HSPA Wireless (Optus Wholesale)
Huawei E169 Modem

Installation environment was on Windows XP Home

Issue:

When attempting to connect, the network connection would attempt to Authenticate, then return with an Error reading "Error 619: A connection to the remote computer could not be established, so the port used for this connection was closed." This would occur 75% of the time when attempting to connect. A workaround was to edit the profile within the Wireless Broadband software replacing the APN: value of 'Connect' with 'exetel1'. Even though the profile change was saved, the value would default back to 'Connect' when viewing the profile once again, or restarting the Wireless Broadband software.

More info:

Following the instructions provided for Configuring Your E169 Modem purchased from Exetel where the Wireless Broadband software prompts for a 'SP CODE' to be entered, entering 'BROADBAND' does not update the APN in the profile to 'exetel1'.
To check this, start the Wireless Broadband software and select 'Tools' menu, then 'Options...' Click on the 'Profile Management folder in the Left hand side column. The Profile Name of 'Wireless BB (Default)' is listed. When the problem was experienced the profile displayed an APN: of 'Connect'.


Possible Resolution:

Two files located at C:\Program Files\Wireless Broadband\plugins\NetConnectPlugin\ seems to contain that values used in the Wireless Broadband sotware profiles.

I Updated the file C:\Program Files\Wireless Broadband\plugins\NetConnectPlugin\ProfileLib.prof
To do this Scroll down and look for line starting with <Profile name="Wireless BB" then change the value in apn="Connect" to apn="exetel1"

Once the file was saved, the profile had an APN of 'exetel1' in it, and the modem connects to Optus on all but on of the 20 plus connection tests I completed across both machines. The one failure seemed to be a significant time to connect so I cancelled the attempt.

User avatar
CoreyPlover
Volunteer Site Admin
Posts: 5922
Joined: Sat Nov 04, 2006 2:24 pm
Location: Melbourne, VIC

Re: Error 619 on Connection Attempt to Exetel Wireless BB

Post by CoreyPlover » Tue Dec 23, 2008 9:21 pm

Although I'm not an Exetel engineer, that sounds like a great workaround for this issue. Thank you for taking the time to post your findings

User avatar
Gidget
Volunteer Site Admin
Posts: 1806
Joined: Wed Jan 28, 2004 4:33 am
Location: Sydney

Re: Error 619 on Connection Attempt to Exetel Wireless BB

Post by Gidget » Mon Mar 23, 2009 2:22 pm

Hi mcalong

I just wanted to add my thanks to you for posting this thread :D

I have been helping a friend set up his new HSPA service, made a bit more difficult with me being in Sydney and he in Brisbane.

He had the same 619 error after apparently successfully entering and saving "exetel1" as the APN - the setting kept reverting to "Connect". After following your clear instructions the correct setting now seems to have "stuck" :D

He is using Windows Vista.

Thanks again for taking the trouble to post the solution.

Cheers

Gidget
Log a fault ticket here
or call Exetel VOIP numbers (02) 8030 1000 or 1300 788 141 (log faults 24x7)
Exetel Support Portal

carsong
Posts: 3
Joined: Fri Mar 17, 2006 8:31 pm
Location: North Rocks NSW

Re: Error 619 on Connection Attempt to Exetel Wireless BB

Post by carsong » Wed Apr 15, 2009 9:49 pm

I found that I couldn't edit the default profile or create a new one while the E169 was connected to the USB port. Every time I clicked on new or edit I would get a pop-up asking if I wanted to save the changes even though I hadn't had a chance to make any.

In frustration I disconnected the E169 and tried again. Success - I could create a new profile and enter the required exetel1 in the APN and save it.

Successfully connected after this change.

User avatar
Lawrie
Posts: 311
Joined: Mon Jun 09, 2008 10:45 pm
Location: Unanderra

Re: Error 619 on Connection Attempt to Exetel Wireless BB

Post by Lawrie » Fri Aug 28, 2009 4:59 pm

I have experienced a similar issue with a Huawei E1762 modem that I talked my colleague into purchasing through Exetel.

The software did not auto install (this may be due to the setup of the PC - is it possible to stop USB memory sticks from auto loading?????)

Anyway I manually ran the setup program off the Modem/memory and I can got the connection application installed, but it will not save the APN parameter, so we have to manually enter it before each connection.

I will try to edit the file C:\Program Files\Wireless Broadband\plugins\NetConnectPlugin\ProfileLib.prof next time I see my colleague to change the value in apn="Connect" to apn="exetel1"
But is this problem related to the auto installation not running successfully?
Are there multiple executables that needed to run?

I will post back on Monday night after trying to manually update the APN

User avatar
Gidget
Volunteer Site Admin
Posts: 1806
Joined: Wed Jan 28, 2004 4:33 am
Location: Sydney

Re: Error 619 on Connection Attempt to Exetel Wireless BB

Post by Gidget » Fri Aug 28, 2009 5:58 pm

Lawrie wrote:I have experienced a similar issue with a Huawei E1762 modem that I talked my colleague into purchasing through Exetel.

The software did not auto install (this may be due to the setup of the PC - is it possible to stop USB memory sticks from auto loading?????)

Anyway I manually ran the setup program off the Modem/memory and I can got the connection application installed, but it will not save the APN parameter, so we have to manually enter it before each connection.

I will try to edit the file C:\Program Files\Wireless Broadband\plugins\NetConnectPlugin\ProfileLib.prof next time I see my colleague to change the value in apn="Connect" to apn="exetel1"
But is this problem related to the auto installation not running successfully?
Are there multiple executables that needed to run?

I will post back on Monday night after trying to manually update the APN
Hi Lawrie

Did you make sure to create a new profile, rather than editing the existing Optus one? That was where I found I went wrong with the first one I installed (over the phone I must say :D ). By creating a new profile, the non-saving of the correct APN problem disappeared.

Gidget
Log a fault ticket here
or call Exetel VOIP numbers (02) 8030 1000 or 1300 788 141 (log faults 24x7)
Exetel Support Portal

Conduit
Posts: 26
Joined: Sun Aug 09, 2009 8:51 pm
Location: Hervey Bay , Qld

Re: Error 619 on Connection Attempt to Exetel Wireless BB

Post by Conduit » Sun Aug 30, 2009 9:20 pm

Hi Lawrie

Did you make sure to create a new profile, rather than editing the existing Optus one? That was where I found I went wrong with the first one I installed (over the phone I must say :D ). By creating a new profile, the non-saving of the correct APN problem disappeared.

Gidget

That's exactly what i did , took me 2 days of scratching the head just after I signed up to work it out , perhaps a hint to new users ( on paper , with the modem ) to do this would save some headache ? I went through an agent and even he was unaware that the default profile did not "stick"

User avatar
Lawrie
Posts: 311
Joined: Mon Jun 09, 2008 10:45 pm
Location: Unanderra

Re: Error 619 on Connection Attempt to Exetel Wireless BB

Post by Lawrie » Mon Aug 31, 2009 5:32 pm

Thanks Gidget and Conduit. YES! by creating the new profile, the APN now saves as required.

I now remember when I bought my HSPA service 9 months ago the instructions specified creating a new profile, but when following the instructions last week when setting up my colleagues new service, I don't recall seeing this step.

Then again, I am a bloke, and following instructions does not come naturally.............. :lol:

RWC
Posts: 3
Joined: Sat Mar 05, 2011 8:10 am
Location: australia

Re: Error 619 on Connection Attempt to Exetel Wireless BB

Post by RWC » Sun Mar 06, 2011 1:20 pm

...Updated the file C:\Program Files\Wireless Broadband\plugins\NetConnectPlugin\ProfileLib.prof
To do this Scroll down and look for line starting with <Profile name="Wireless BB" then change the value in apn="Connect" to apn="exetel1"
This worked for me BUT everyone needs to be aware that there are two such headings in that list!
It seems to be the second one that needs to be changed,not the first :shock:

Post Reply