Internet drops out but still connected?

HSPA setup and configuration (for wireless networking, please use the 'Networking issue' forum)
Post Reply
wsr2006
Posts: 3
Joined: Thu Sep 24, 2009 9:00 pm
Location: Mosman PArk, WA

Internet drops out but still connected?

Post by wsr2006 » Mon Sep 28, 2009 10:06 pm

Howdie,

Just got Exetel mobile broadband a few days ago connecting with the Huawei E1762 HSPA USB stick.

There are 2 problems I'm getting:

1. The connection to the internet keeps dropping out whilst still connected to the network (ie icon doesn't show the little globe anymore..). Usually this happens after 10 to 15 minutes.

2. Probably related to 1. After the connection fails and trying to reconnect, Error 619 shows up (Error 619:A connection to the remote computer could not be established, so the port used for this connection was closed). The only way to reconnect is by completely restarting the computer.

Settings of the Broadband program are fine ('exetel1', static etc) and signal strength is always above 94%. Running on Windows Vista.

Any ideas what is causing the constant drop outs and how to fix? I haven't tried the ping solution yet but from what I've read this doesn't always fix it anyway.

Thanks!

CoreyPlover
Volunteer Site Admin
Posts: 5922
Joined: Sat Nov 04, 2006 2:24 pm
Location: Melbourne, VIC

Re: Internet drops out but still connected?

Post by CoreyPlover » Mon Sep 28, 2009 11:15 pm

wsr2006 wrote:Any ideas what is causing the constant drop outs and how to fix? I haven't tried the ping solution yet but from what I've read this doesn't always fix it anyway.
No, I don't know how to fix it but the ping solution is a very good thing to try.

Another good test is to try the mobile broadband somewhere else to see if it might be related to the particular mobile tower.

cubic
Posts: 161
Joined: Tue Nov 16, 2004 11:19 am
Location: Lake Macquarie NSW

Re: Internet drops out but still connected?

Post by cubic » Tue Sep 29, 2009 9:16 am

Could be a local tower problem but I think the 619 error usually indicates a misconfiguration. Have you checked the settings after this happens, and before you reboot? Did you create a new connection with the exetel1 AP or edit the existing connection?
...the term 'Future Perfect' has been abandoned since it was discovered not to be - Douglas Adams

CoreyPlover
Volunteer Site Admin
Posts: 5922
Joined: Sat Nov 04, 2006 2:24 pm
Location: Melbourne, VIC

Re: Internet drops out but still connected?

Post by CoreyPlover » Tue Sep 29, 2009 9:32 am

Check out http://forum.exetel.com.au/viewtopic.ph ... 78#p230278 for a similar 619 error and how creating a new profile with APN = exetel1 fixed it.

wsr2006
Posts: 3
Joined: Thu Sep 24, 2009 9:00 pm
Location: Mosman PArk, WA

Re: Internet drops out but still connected?

Post by wsr2006 » Tue Sep 29, 2009 11:07 pm

Hello,

Have tried the ping solution and that seems to work (ping -t -l 1 www.google.com.au). Connection doesn't drop anymore and skype etc works fine - so that's good.

Is it normal to have this running in the background just so that I'm able to use the internet? Or is there a technical issue somewhere?

Cheers!

CoreyPlover
Volunteer Site Admin
Posts: 5922
Joined: Sat Nov 04, 2006 2:24 pm
Location: Melbourne, VIC

Re: Internet drops out but still connected?

Post by CoreyPlover » Wed Sep 30, 2009 12:13 am

wsr2006 wrote:Is it normal to have this running in the background just so that I'm able to use the internet? Or is there a technical issue somewhere?
It is a workaround and many services work well without it so I don't know exactly what causes it. The reasoning is that the device will automatically downgrade from high speed HSPA to regular speed WCDMA when idle for 10-20 seconds in order to free up the connections to the mobile tower. But in some instances, this regular switching between bands causes issues (not sure why). The constant ping prevents the connection from being classified as idle and so a constant HSPA connection is maintained.

toast
Posts: 103
Joined: Tue Sep 26, 2006 1:52 pm

Re: Internet drops out but still connected?

Post by toast » Wed Jun 09, 2010 11:55 am

I have the same issue, I'm using a Dell inspiron mini with built in 3G modem 'Dell Wireless 5540 HSPA Mini-Card Modem' it also suffers this problem. If there is an amount of idle time it will then either drop in speed to painfully slow, or just plain stop working.

I have found a solution to not resetting the computer however. I can turn off the hardware and turn it back on again via the 'Wireless Enable Disable' application (on the F2 key on the netbook).

It does mean you need to disconect and reconnect, so it's annoying.

Are the reports due to the type of modem, or do people with the same modem type also not experience this problem. From the posts above it does not seem just related to Exetel as I read it to be a problem between the SIM and the tower to reduce congestion.

From this post on whirlpool http://forums.whirlpool.net.au/forum-re ... 47888.html I've now only selected WCDMA I, WCDMA II, WCDMA VIII, and GSM 850, see how that goes.

Are there ping programs that only ping every minute? I don't want to send 40 bytes every second.. when I could send them every minute, the bytes add up to cents eventually.

Dazzled
Volunteer Site Admin
Posts: 6003
Joined: Mon Nov 13, 2006 1:16 pm
Location: Sydney

Re: Internet drops out but still connected?

Post by Dazzled » Wed Jun 09, 2010 12:32 pm

Toast, Windows' ping is rather limited - http://www.microsoft.com/resources/docu ... x?mfr=true whereas Mac and Linux have the -i argument to vary the timing - http://developer.apple.com/mac/library/ ... ing.8.html and http://linux.die.net/man/8/ping

In Windows you can set up a batch file with wait in it, to time successive pings. You can also ping localhost with a long wait time (-w) alternating with the wanted external ping.

Edit: So in Windows, ping -n 1 -w 30000 127.0.0.1 wastes 30 seconds.
Last edited by Dazzled on Wed Jun 09, 2010 1:34 pm, edited 1 time in total.

CoreyPlover
Volunteer Site Admin
Posts: 5922
Joined: Sat Nov 04, 2006 2:24 pm
Location: Melbourne, VIC

Re: Internet drops out but still connected?

Post by CoreyPlover » Wed Jun 09, 2010 1:31 pm

toast wrote:Are there ping programs that only ping every minute? I don't want to send 40 bytes every second.. when I could send them every minute, the bytes add up to cents eventually.
Assuming an 18 byte packet (which is the minimum) per second, this would add to about 1.5MB a day. To put that into context, a single visit to the Herald Sun page uses more so I wouldn't worry about running a background ping (just set the packet size to the minimum)
I am a volunteer moderator and not an Exetel staff member. As with all forum posts, mine do not constitute any "official" Exetel position. Support tickets may be logged via https://helpdesk.exetel.com.au or residentialsupport@exetel.com.au

toast
Posts: 103
Joined: Tue Sep 26, 2006 1:52 pm

Re: Internet drops out but still connected?

Post by toast » Thu Jun 10, 2010 12:49 pm

Thanks dazzled, I wrote the following batch file

:LoopStart
ping 127.0.0.1 -n 60
REM Pinging www.l.google.com [66.102.11.104] with 1 bytes of data:
ping -n 2 -l 1 66.102.11.104
GOTO LoopStart

so I'll amend it to add the 60 second wait time instead of 60 pings to local host :)

corey, cheers for the dose of reality that pings won't break my bank account :)

I'll be updating the Dell drivers tonight, so maybe that will fix things too... I'll let you know.

toast
Posts: 103
Joined: Tue Sep 26, 2006 1:52 pm

Re: Internet drops out but still connected?

Post by toast » Fri Jun 11, 2010 2:18 pm

I upgraded all my drivers. The 'Dell Wireless HSPA Mini-Card Driver' is now at 6.1.13.8. My Dell Mobile Broadband Manager is now at version 2.1.0.0.

It reports that I'm connected via 'HSPA' where the previous version reported a '3G/UTMS' connection.

I've gone 10 minutes without the connection being 'dropped.' So that's good news.. should last all day now, I'm very happy. I'm very much adoring my little Dell Inspiron netbook :)

toast
Posts: 103
Joined: Tue Sep 26, 2006 1:52 pm

Re: Internet drops out but still connected?

Post by toast » Fri Jun 11, 2010 2:20 pm

P.S.

And I think the Exetel $30 prepaid for 2GB over 90 days is excellent value!

cyberknutt
Posts: 17
Joined: Tue Jan 06, 2009 10:22 am
Location: Melbourne

Re: Internet drops out but still connected?

Post by cyberknutt » Tue Jun 15, 2010 2:39 pm

toast wrote:Are there ping programs that only ping every minute? I don't want to send 40 bytes every second.. when I could send them every minute, the bytes add up to cents eventually.
Try http://vk3kjc.org/files/MultiPing.zip. This will allow you to adjust the delay between pings. This was written for a similar problem that I, and others, had with the Virgin Broadband @ Home system. I think it is a problem with all Optus Wireless but only appears on some towers. In my case their was no definite conclusion but the theory was that I was too close to too many towers.

PS: To change the packet size and packet timeout period double click on the words "Ping Interval" above the text box for ping interval - or edit the ini file.
Ken.

Post Reply