Page 1 of 1

Cannot connect and need help please

Posted: Mon Apr 05, 2010 3:16 pm
by tomartomau
I own a Lenovo X300 with a built in mobile broadband card (Sierra MC8775). I have rung both lenovo (three times) and Exetel once about support for connecting.

This is what I have done.
1. I have activated the sim card as per the instructions, and my account is active. (three days in fact).

2. I have tried using the Sierra Watcher and Access Connections software, but to no avail.

3. I have recognition of the network (Optus) and I have used the correct settings4.

4. The lenovo technician this morning said that I would get an error if the card was locked and because I did not get an error stating this then the card cannot be locked ?

As I mentioned before i can view the network but it will not connect.

Here is a screen dump of the error.

Can someone please assist, I have been trying for three days to connect.

Cheers Tony

P.S On a side note my account is showing like 175mb of usage when I have not even connected to the network once yet?


Connection status: Not connected
Cause: Protocol error(unspecified).
Error code: 089
Recommended action:
The wireless WAN equipment received a protocol error event and no other cause in the protocol error class applies. Please contact your wireless WAN service provider.

If the problem persists, contact your network administrator and provide the troubleshooting information below.

Adapter Details
Adapter name Sierra Wireless HSDPA Network Adapter
Adapter type WAN
Adapter speed 3.6 Mbps
Adapter status Enabled
Connection Status Not connected

Internet Settings
IE Settings
Home page
Proxy settings
Automatically detect settings? Yes
Use automatic configuration script? No
HTTP proxy
HTTPS proxy
FTP proxy
Gopher proxy
Bypass proxy for local addresses? No

System Information
System model 647818M
BIOS version 7TET36WW (1.10 )
TVT GINA version
Operating system version Windows XP, Service pack 3
ThinkVantage Access connections version 5.61

Automatic location profile switching list

Enable automatic location switching -> Yes
Include Ethernet connections in automatic switching and prompt me to save Ethernet ports -> Yes
Preferred Location Of WLAN -> No
When no other connections are available, connect through Wireless WAN or WiMAX -> No

Re: Cannot connect and need help please

Posted: Mon Apr 05, 2010 3:30 pm
by Dazzled
After you raised this problem at what happened?

Re: Cannot connect and need help please

Posted: Mon Apr 05, 2010 4:01 pm
by tomartomau
Dazzled wrote:After you raised this problem at what happened?

I have tried the network connection using the designated *9***# but to no avail. However I am not an expert in networking either.

I know that I should be able to connect using either access connections or the Sierra Watcher utility, however neither are working.

I am thinking that the card is locked?

Cheers Tony

Re: Cannot connect and need help please

Posted: Mon Apr 05, 2010 4:53 pm
by Dazzled
If cubic's reply didn't work and the phone number doesn't either, without having an X300 here, I'm out of ideas. Locking can usually be detected by issuing AT commands to the modem, eg at+cpin? to detect an active PIN on the SIM card, at+cfun? for status etc. These would probably require hyperterminal in a Windows system, but wait for a Windows expert. Have you tried Ubuntu on a live usb stick (not v9.10 though), or even Puppy on usb or CD? If that works it's not locked.
Edit: AT reference: ... e-v2.4.pdf

Re: Cannot connect and need help please

Posted: Tue Apr 06, 2010 8:20 pm
by tomartomau
I have resolved the problem and I am typing using the WWLAN network as I type. Basically I have contaqcted Lenovo two times since posint this thread. I must say the people I talked to were reluctant to assist and were vague in their assessment of the issue. I said that as the computer is fitted with a factory FRU Card and that they provide the software for the installed and supported operating system then they have an obligation to rectify the device problem (not the connection issue).

Basically Lenovo could not commit to either a yes or a no if the caard was locked and recommended I contact Vodaphone to find out for sure if the card is locked. One operator suggested that I wipe my computer of Win XP and use another operating system. Well I have installed Win 7 and all is good, however I had to search the internet for a driver for Win 7. It now works well, and I put the problem down to Win xp service pack 3.

Cheers and thanks for all your support.