TP-Link MA260 3G USB modem crash

HSPA setup and configuration (for wireless networking, please use the 'Networking issue' forum)

Re: TP-Link MA260 3G USB modem crash

Post by thejeg » Tue Jan 14, 2014 9:00 am

CLoSeR wrote:This is a problem affecting a number of customers, in this thread alone there are three of us reporting the same issue.

I've already tried re installing and I have no desire to spend any more time troubleshooting for TP-Link. I've been working in IT for many years and I just shudder to think how any non technical person handles this problem, Exetel should really be thoroughly testing hardware internally before promoting it for use with your service.

I want to send the modem back for a refund.
I do understand that this is an issue affecting couple of customers.

I'm still in contact with TP-Link awaiting for a positive response and I have explained them that the basic troubleshooting has not given us any positive outcome.

Please standby till I get a response from them but in the mean time, if you would want to have a refund for the modem, please call Exetel Support, quote this Thread and obtain a reference number. Once done, send the modem back to us and upon receiving the modem in good condition, we will refund you the total cost for the modem.

Posts: 858
Joined: Fri Jun 11, 2004 1:49 pm
Location: West Ryde, NSW

Re: TP-Link MA260 3G USB modem crash

Post by CLoSeR » Tue Jan 14, 2014 9:32 am

James wrote:Chris, do you have any other mobile broadband software on your computer/laptop? Have you tried this on another computer.

I've tried this on two separate machines both running Windows 7 64 bit, one is a desktop and the other is a Toshiba laptop. I even tried using a different connection manager and the drivers seem to crash that application also, I think it has something to do with the hardware. It's strange as the TP-Link connection utility will happily run allowing me to configure the profile required etc however once you connect the modem and it registers on the network stating "YES OPTUS" next to the signal icon the application will crash.

The problem is that this service was purchased for a family member who lives on the Central Coast and as I live in Sydney I spent a few hours trying to make this work at the weekend before heading home. They are relocating and will soon be without access to ADSL and need a working connection. From what I have read I am reasonably confident that if I purchase an prepaid Optus 3G modem that I should be able to swap the sim and change the APN for use on the Exetel service.

I just want the service to work so everyone is happy.
Need to log a fault ticket? Go here:

Volunteer Site Admin
Posts: 6003
Joined: Mon Nov 13, 2006 1:16 pm
Location: Sydney

Re: TP-Link MA260 3G USB modem crash

Post by Dazzled » Tue Jan 14, 2014 11:06 am

CLoSer, there's an internet full of users whose device stops like this. My own cynical view, backed by too many bad experiences, is to never buy anything that doesn't have an open source driver, so I tried to find some diagnostics from a Linux box (yes, they are having the same trouble. but these systems have logs).

From what I found: it gets modeswitched, the pppd daemon logs are happy for a while, the device gets going, gets CHAP, sorts out IP and DNS, ifup reports it is happy with resolv.conf, the firewall is good, everything is rosy, we're off -- and then....
The kernel spoils the party and posts a USB disconnect.
The daemon considers this as a hangup, and proceeds normally to close. Before the crash, 530 bytes had been sent, 152 received on the logs I found.


Re: TP-Link MA260 3G USB modem crash

Post by thejeg » Fri Jan 17, 2014 7:48 pm

CLoSeR wrote:I just want the service to work so everyone is happy.
For those who experienced a crash / application conflict when using MA260 3G USB modem, our modem vendor has figured out that this issue is caused by empty message in the SIM card and as such they have made a new utility.

Steps below will resolve the issue.

1. unplug MA260 3G USB modem from your computer.
2. uninstall the existing utility of MA260.
3. restart the computer.
4. plug MA260 into your computer but don’t install the utility when prompted.
5. Download the utility from ... tility.rar and install it.
6. try to see if this issue still exist.

Please post the results after following the above steps.

Post Reply