Echo on outgoing VOIP calls

VOIP setup and troubleshooting
Post Reply
lolapola
Posts: 2
Joined: Thu Oct 02, 2008 9:58 pm
Location: sydney

Echo on outgoing VOIP calls

Post by lolapola » Mon Nov 10, 2008 4:20 pm

Hi,

I've got Naked ADSL2+ VOIP service with Extel. From day one I could hear (incoming) calls clearly but my out going calls had an echo. Recently when i called my home phone and heard the echo it was really alloying. I started making business calls and my clients are complaining. This needs to be sorted out asap. Could you please help me ?

I got Billion 7404 modem. I tested the speed of my connection and its usually
"13.11 Mbps which means you can download at 1.64 MB/sec. from our servers." I tried doing the speed test after every 15mins and its usually around 10Mbps. I turned the computer off but still there's an echo. Did everything possible. Now i seek your help.

Let me know if you want me to post my service number here or private msg you.

dbr
Posts: 493
Joined: Fri Feb 08, 2008 2:33 pm
Location: Sale VIC

Re: Echo on outgoing VOIP calls

Post by dbr » Mon Nov 10, 2008 5:28 pm

Which Codec are you using?
What phone type do you have plugged in? Does it occur on a wireless handset? Try with an 'old' corded telephone.
Have you adjusted the volume on the line in the modem?
Is it every outgoing call or intermittent?
Does it occur if you use a softphone?
Do you have QOS set up correctly?
http://www.saferoz.com.au
First Aid * Fire * Safety

silentmonkey
Posts: 2
Joined: Tue Aug 21, 2007 6:46 pm
Location: Sydney

Re: Echo on outgoing VOIP calls

Post by silentmonkey » Mon Feb 02, 2009 5:10 pm

lolapola,

Did you ever get this fixed up? I'm having similar problems with our VOIP line but couldn't find any thread in these forums which fit the description except for yours.

I am using a Billion BiPAC 7401VGP with no line filter.

QoS is set to 'Best Effort'.

Codec for the port is G.729.

The home line (using cordless or fixed phones make no difference) has no problem hearing the other person. But the other person may have one or two echos depending on whether we called them or they called us, respectively.

I can give more information if needed. Has anyone managed to fix this problem with their VOIP?

AngusCS
Posts: 9
Joined: Thu Aug 24, 2006 3:23 am

Re: Echo on outgoing VOIP calls

Post by AngusCS » Mon Feb 09, 2009 7:13 pm

I also have this issue with a Billion 7402VGO.

I initially set it up using 711 as that would seem to be the suggested best codec for the billions. I am getting really bad echo on the local phone if I dial out to a landline on the VOIP number, and really bad echo on the calling end if I dial in to the landline number.

I have changed the handsets on the router and this has not changed the problem

I have switched to the 729 codec and this has made no difference
Great Scott, It'll end in tears!

jokiin
Volunteer Site Admin
Posts: 2970
Joined: Mon Feb 02, 2004 10:23 pm
Location: Sydney

Re: Echo on outgoing VOIP calls

Post by jokiin » Mon Feb 09, 2009 7:34 pm

AngusCS wrote:I also have this issue with a Billion 7402VGO.

I initially set it up using 711 as that would seem to be the suggested best codec for the billions. I am getting really bad echo on the local phone if I dial out to a landline on the VOIP number, and really bad echo on the calling end if I dial in to the landline number.

I have changed the handsets on the router and this has not changed the problem

I have switched to the 729 codec and this has made no difference
you need to adjust the speaker and mic volume in the setup of the Billion, it might take a bit of trial and error but you should be able to sort it out, this is a very common complaint with these models

sable
Posts: 651
Joined: Tue Jan 20, 2004 9:28 am
Location: NSW

Re: Echo on outgoing VOIP calls

Post by sable » Mon Feb 09, 2009 8:17 pm

Go to Configuration/VOIP/PhonePort/Edit

Then at bottom LHS click volume control

Make Mic volume less than speaker volume, from memory the default is equal at 5 bars each, I have mine set at Mic 3 and Speaker 5

then click return and save the config to flash

It is the differential that gets rid of the echo

As to the codec I have mine set to the Billion recommendation of G.711 in Priority 1 and nonused everywhere else, works ok for me with Exetel server

AngusCS
Posts: 9
Joined: Thu Aug 24, 2006 3:23 am

Re: Echo on outgoing VOIP calls

Post by AngusCS » Mon Feb 09, 2009 9:08 pm

Thank you both for your answers. I have 12 bars available on the 7402 and I now have it set on Mic 5 and Spkr 9. This is better but not totally fixed.

Can you please tell me if I should be using 711 A-Law or 711 U-Law as the primary??
Great Scott, It'll end in tears!

jokiin
Volunteer Site Admin
Posts: 2970
Joined: Mon Feb 02, 2004 10:23 pm
Location: Sydney

Re: Echo on outgoing VOIP calls

Post by jokiin » Mon Feb 09, 2009 9:52 pm

AngusCS wrote:Thank you both for your answers. I have 12 bars available on the 7402 and I now have it set on Mic 5 and Spkr 9. This is better but not totally fixed.

Can you please tell me if I should be using 711 A-Law or 711 U-Law as the primary??
you still may need to fine tune the settings to get the best result, for the codec use A-law but as long as you don't lock it to a single codec it will negotiate the correct codec as required anyway

silentmonkey
Posts: 2
Joined: Tue Aug 21, 2007 6:46 pm
Location: Sydney

Re: Echo on outgoing VOIP calls

Post by silentmonkey » Sat Mar 14, 2009 2:17 pm

Sable,

Thanks for the details on how to configure the speaker and mic volume. It seems to have helped reduce the audible echo a little and has made conversation almost bearable! (Almost.)

My bars go up to 13 and currently the mic volume is 2 and the speaker volume is 8.

As per jokiin's suggestion, I have also changed my codec to 711 A-Law.

Are there any other suggestions for things to try, as I don't think the volume change is fixing the problem enough.

Thanks for everyone's input so far! Hopefully soon our phone may be usable and my housemates will get off my back about fixing it =)

outbush
Posts: 327
Joined: Fri Jun 08, 2007 8:49 am

Re: Echo on outgoing VOIP calls

Post by outbush » Sat Mar 14, 2009 2:23 pm

silentmonkey wrote:My bars go up to 13 and currently the mic volume is 2 and the speaker volume is 8.
I would set the mic to about 3 and the speaker to 4.
I think 8 is a bit high from my past experience

Post Reply