Page 1 of 1

VOIP Outgoing calls lost after 30 seconds

Posted: Fri Mar 18, 2011 8:10 pm
by Wazzaf
Hello Friends

Long time since I have had any issues with VOIP but something strange has started happening over the last week or two. I have not made any configuration changes.

I have been using Counter Path Eyebeam Version 1.5.20.2 Build 59031 to make calls from my Laptop without any issues until recently. 99% of the time I only use it for outgoing calls

What is now happening is that calls are terminating after 30 - 33 seconds and if I redial the same happens again. Never shorter than 30 seconds and always in mid sentence when you are talking. This has made VOIP unuseable which is not good as I depend on it.

Can anyone suggest how I can troubleshoot to a resolution.

Cheers

Re: VOIP Outgoing calls lost after 30 seconds

Posted: Fri Mar 18, 2011 9:15 pm
by CorporateVoIP
One of our corporate customers was experiencing the same issue and it was firewall related. I will ask one of our developers (who identified the issue) to respond.

Re: VOIP Outgoing calls lost after 30 seconds

Posted: Fri Mar 18, 2011 9:57 pm
by Dazzled
I know a Twinkle user with this problem too, and short of Wiresharking the laptop, I haven't worked it out either. It's spot on 30 seconds. Ekiga on the same laptop however continues on as long as desired. Twinkle used to work correctly too. I did check iptables on the laptop, and it isn't the firewall. It started round about last December.

Re: VOIP Outgoing calls lost after 30 seconds

Posted: Sat Mar 19, 2011 8:56 am
by Wazzaf
Thanks CorporateVOIP and Dazzled for responding.

Played around some more and it happens both using my HSPA and Daughters ADSL.

Strangely also tried X-Pro softphone and it worked OK. Dont really want to change from Eyebeam as I paid for it and it has always worked well. Could it be a Codec? (Clutching at straws I Know)

I am happy to send all settings and try anything.

Cheers

Re: VOIP Outgoing calls lost after 30 seconds

Posted: Sat Mar 19, 2011 10:06 am
by Dazzled
Wazzaf, it's not likely to be codecs dropping out at 30 secs. In the case I know of, both the Twinkle and Ekiga softphones are using the same codecs (they are free softphones, so no G.729), and since they are both on the same Linux laptop, they are behind the same iptables rules. The laptop kernel hasn't been updated for a long time, if ever. Twinkle worked satisfactorily once on this device.

The problem will more likely be connected with the softphone's handling of the control signals to and from the VoIP server. Unfortunately, without setting up something like wireshark (eg, http://everythingvoice.blogspot.com/201 ... using.html) it is difficult to observe these signals on many softphones, although Twinkle, at least, keeps a log similar to an ATA's. Have a look to see if Eyebeam logs a useful record of server interactions (INVITE, etc). If so, post what it says up to and after the dropout, as it may help CorporateVoIP.

I remember that after some temporary changes last year Billion ATAs ran into strife for a while.

Re: VOIP Outgoing calls lost after 30 seconds

Posted: Sat Mar 19, 2011 10:54 am
by Wazzaf
Thanks Dazzled

Just now posted the same as an issue on Counterpath Support Forum and will let you know if I get a response.

Eyebeam does create logs and I just tested a call again and it dropped out exactly at 33 seconds.

Rather than cut and paste the log files I have uploaded as an attachment as it is huge. No idea of what story the contents are telling and are hoping you can see something.

If all else fails I am OK to give Wireshark a go but am not capable of interpreting any output so would need some help.

Cheers

Re: VOIP Outgoing calls lost after 30 seconds

Posted: Sat Mar 19, 2011 10:56 am
by Wazzaf
Hi Dazzled

Looked at my newest post and I cant tell up the upload worked ???

Cheers


OK it seems I cannot upload .txt or .doc files. Can I email it?

Re: VOIP Outgoing calls lost after 30 seconds

Posted: Sat Mar 19, 2011 11:30 am
by Dazzled
You can upload an image format if it's not too big. The file can probably be made smaller if you clear the log, then make a cut-off phone call, then read the log again. You could then either add the shortened log as an email attachment sent to Support with your ticket number, or maybe post it here as Code.

Re: VOIP Outgoing calls lost after 30 seconds

Posted: Sat Mar 19, 2011 11:54 am
by CorporateVoIP
Dazzled is quite correct about it being a control signal issue.

From memory, the call/stream will establish correctly however there's a return signal that gets mis-routed and the call gets dropped after a number of failed retries. Sadly I can't remember whether it's the client or the server that does the disconnect.

I have emailed Jing, but he may not see the mail until Monday.

Re: VOIP Outgoing calls lost after 30 seconds

Posted: Sat Mar 19, 2011 1:05 pm
by Wazzaf
Ok Thanks

Logging was turned off before i made one call. Made one call and it created 4 very large text file so I have opened a ticket #3761681 and attached the four text files.

Appreciate your help and will now patiently wait until Monday

Thanks again

Cheers

Re: VOIP Outgoing calls lost after 30 seconds

Posted: Tue Mar 22, 2011 8:16 am
by Wazzaf
All seems to be fixed.

Received an email from Jing T Exetel Residential Support advising that he had made a change to my SIP account. Dont have details of the change but I tested with calls both to landline and mobile are they worked OK.

I certainly am appreciative of the prompt action and the support offered by this formum. Congratulations.

Cheers