Exetel VoIP Setup Guide for TP-Link TD-VG3631 VoIP modem

VOIP setup and troubleshooting
Post Reply
sac9829
Posts: 5
Joined: Sat Jan 26, 2008 12:50 pm
Location: Brisbane

Exetel VoIP Setup Guide for TP-Link TD-VG3631 VoIP modem

Post by sac9829 » Mon Dec 10, 2012 10:37 pm

Hi

Looking for a setup guide for the following VoIP modem:

TP-Link TD-VG3631 VoIP modem

As can't get the incoming calls to our VoIP DID to work correctly.

As the caller and receive both can't hear each other.

User avatar
Dazzled
Volunteer Site Admin
Posts: 6002
Joined: Mon Nov 13, 2006 1:16 pm
Location: Sydney

Re: Exetel VoIP Setup Guide for TP-Link TD-VG3631 VoIP modem

Post by Dazzled » Tue Dec 11, 2012 6:45 am

No incoming audio is often a problem with RTP packets passing a NAT firewall, or a wrong audio codec. The benefit of an all-in-one device is that the firewall setup has been done by the maker, so first have a close look at your audio codecs - give G.729 priority for all connected services, then G.711 A . (μ is for USA)

With some ATA boxes behind a modem-router an ALG setting can get in the way - just reverse whatever the current setting is, and see if it works, though all-in-one makers set this up correctly too, so it's pretty unlikely.

Some other settings that come to mind:
Profile name, Phone number, Display Name, Auth ID, - your 10 digit VoIP phone number
Registrar address, SIP proxy, Outbound proxy - 58.96.1.2
Register via outbound - on
PTime - 20
Incoming route for calls - all

Change the emergency PSTN call number to 000 for Australia. This is because an emergency call sent via VoIP cannot be traced to a location. Go to SIP Advanced to change the USA tones.

sac9829
Posts: 5
Joined: Sat Jan 26, 2008 12:50 pm
Location: Brisbane

Re: Exetel VoIP Setup Guide for TP-Link TD-VG3631 VoIP modem

Post by sac9829 » Tue Dec 11, 2012 9:14 am

Thanks for the reply.

Yes is all in one so shouldn't be a firewall or NAT issue.

Have been trying different codecs and currently have G.729 as the main codec but still doesn't seem to work.

Thanks for the other setting details. Have checked this and that is currently what is set.

Any other ideas?

User avatar
Dazzled
Volunteer Site Admin
Posts: 6002
Joined: Mon Nov 13, 2006 1:16 pm
Location: Sydney

Re: Exetel VoIP Setup Guide for TP-Link TD-VG3631 VoIP modem

Post by Dazzled » Tue Dec 11, 2012 5:48 pm

Are the incoming calls with no audio from a PSTN source, or are they via a VoIP service? Does your VoIP handset ring for both kinds of call?

If they are PSTN calls, check the cabling - a filtered cable goes into LINE and and another unfiltered cable into ADSL. In a TP-Link splitter, the unfiltered port is MODEM. PSTN analogue input calls bypass the router firewall tables, while VoIP digital packets on the ADSL input are processed.

sac9829
Posts: 5
Joined: Sat Jan 26, 2008 12:50 pm
Location: Brisbane

Re: Exetel VoIP Setup Guide for TP-Link TD-VG3631 VoIP modem

Post by sac9829 » Wed Dec 12, 2012 10:31 am

Dazzled wrote:Are the incoming calls with no audio from a PSTN source, or are they via a VoIP service? Does your VoIP handset ring for both kinds of call?

If they are PSTN calls, check the cabling - a filtered cable goes into LINE and and another unfiltered cable into ADSL. In a TP-Link splitter, the unfiltered port is MODEM. PSTN analogue input calls bypass the router firewall tables, while VoIP digital packets on the ADSL input are processed.
Have been testing by calling in from a mobile.

Just had exetel test from a VoIP number and seem to be able to hear the incoming caller.

Have tried a different filter from DSE but same issue.

User avatar
Dazzled
Volunteer Site Admin
Posts: 6002
Joined: Mon Nov 13, 2006 1:16 pm
Location: Sydney

Re: Exetel VoIP Setup Guide for TP-Link TD-VG3631 VoIP modem

Post by Dazzled » Wed Dec 12, 2012 11:47 am

If the mobile rang your VoIP number, it's an incoming VoIP call, ie digital. If you had filter problems digital internet usage would likely also be affected, so it's not at the top of things to test.

VoIP calls are established by a number of signals (using the UDP protocol) swapped between you and the Exetel server on port 5060 to set up ready for the audio transfer. When ready, the audio is transferred on a high numbered port, digitally encoded (and sent using the RTP protocol). If the encoder/decoder software (codec) goes wrong or the method used is unsupported, you usually get silence when the audio should happen.

I don't have one of your devices to try, but to chase up a clue, if you look up the system tools->system log straight after a call you might/perhaps/maybe get a cryptic SIP error message concerning a codec (the call logging starts with the INVITE signal). Run the log at say Notice level - Debug gets too extreme - Linux at system level is extremely verbose.

Post Reply