Page 1 of 1

Linksys pap2t issues

Posted: Sat Dec 29, 2012 12:30 pm
by mickford
]Hi and thanks for the forum, I hope you can help :)

I have had the exetel voip service running well using a voip capable Netgear modem/router DG834GV v2(easy config) for some time, however it has become unreliable. Hence I bought an ATA - Linksys pap2t (complex config) and configured and reconfigured many times, according to exetel wiki here - ... ksys_PAP2T
I also portforwarded in router ... 5060-5061, 10000-20000, 69, 53 ... UDP ports

I have an audible dial tone, and the numbers sound normal as they are dialed but there is no connection/ringtone, only neverending silence - this occurs with local, longdistance and mobile numbers.

I have screenshots of each of the config pages and info page from the pap2t web facility but can only u/l 3 here. I look forward to your advice, cheers!
1.jpg (167.79 KiB) Viewed 3172 times
line1 top
line1a.jpg (121.01 KiB) Viewed 3172 times
line1 bottom
line1c.jpg (112.85 KiB) Viewed 3172 times

Re: Linksys pap2t issues

Posted: Sat Dec 29, 2012 1:23 pm
by Dazzled
The dial tones come out of the ATA to the handset, but you sound as if the ATA is offline or not registered.

Quickies--- Does the ATA show that the VoIP service is registered? Are you using the Netgear DG834 for a router still? Why did you choose for a static IP? Check that it is within the starting and ending range of the router DHCP server.

You must forward 5060 UDP (TCP is not needed) if you want to receive an incoming ring through the router firewall. Outward calls don't care. A simple test to see if you screwed up forwarding is to put the ATA address into a DMZ - that forwards everything and should always work.

I'll try to look at the ATA config later. G.711A is a more reasonable 1st codec.

Re: Linksys pap2t issues

Posted: Sat Dec 29, 2012 3:59 pm
by Dazzled
Just a quick look - you are receiving and sending SIP bytes, which are the control signals. You have 0 RTP bytes, which should be the audio stream, so something appears amiss with the SIP handling that actually sets up the RTP stream.

Use as both the Exetel proxy and outbound proxy address, and you won't need a DNS lookup at all. The display name should be your SIP phone number. Bhagyam's wiki post shows his (falsified) phone number for each of Display Name, Auth ID and User ID. Use yours. The password is the VoIP password sent to you.

There's also a decent guide at Remember though he's not putting Exetel as the proxy server, so fill the fields mentioned in the para above as described there.

Re: Linksys pap2t issues

Posted: Sun Dec 30, 2012 12:32 pm
by mickford
Thanks for the reply Dazzled, you've given me a bit to chew on, thankyou, I'll get back later on ;)

Re: Linksys pap2t issues

Posted: Thu Jan 03, 2013 4:33 pm
by mickford
Sadly the only change that made a difference was the longer dialing plan from the 2 setup guides - (*x.x.) versus (*xx|<0:061>[23478]xxxxxxxxS0|<:**6>1800xxxxxx|<:0612>13xx.|xx.)
which connects me to local calls but not mobile or long distance. And no setting allows inbound calls regardless of DMZ settings.

But thanks for trying :)

EDIT: I found another dial plan which does work for me here - (*xx|13[1-9]xxxS0|1[38]00xxxxxxS0|190xxxxxxx!|000S0|0011xxxxx.|[2-9]xxxxxxxS0|0[2-9]xxxxxxxxS0)

So I can now dial out anywhere :) but sadly inbound calls to my PSTN number do not connect :?

Re: Linksys pap2t issues

Posted: Thu Jan 03, 2013 6:45 pm
by Dazzled
No incoming calls is usually a problem with the INVITE packet not passing the router. If a valid reply from the ATA isn't received by the server you'll get no further packets.

The manufacturer's FAQ states for this problem:
Go through this checklist until your problem is solved:
• Make sure the telephone is plugged into the correct port, PHONE 1 or PHONE 2. (You should use the
Phone 2 port only if you have more than one Internet telephone service account.)
• Make sure the ringer volume on your telephone is set to an audible level.
• Follow these instructions to reboot your cable or DSL modem, Phone Adapter, and router:
1. Power off your cable or DSL modem by unplugging its power adapter.
2. Power off the router by unplugging its power adapter.
3. Power off the Phone Adapter by unplugging its power adapter.
4. Wait two minutes, then power on your cable or DSL modem by plugging its power adapter into an
electrical outlet.
5. Wait two minutes, then power on the router by plugging its power adapter into an electrical outlet.
6. Wait five minutes, then power on the Phone Adapter by plugging its power adapter into an electrical
7. Reboot one of your networked computers, and check to see if you have an active Internet connection.

• Set up port forwarding on your router. You must specify that ports 5060-5061 (UDP), 53-53 (UDP),
69-69 (UDP), and 10000-20000 (UDP) are forwarded to the IP address of the Phone Adapter.
Before you set up port forwarding on your router, change two of the Phone Adapter’s settings using its
Interactive Voice Response Menu. First, disable its DHCP feature, then assign a static IP address to the
Phone Adapter. See “Chapter 4: Using the Interactive Voice Response Menu” for instructions.
The first part is to ensure addressing works. The second is to pass the router firewall. If this doesn't work. open a DMZ from the router to the ATA address. That opens all ports and protocols to the ATA.

Re: Linksys pap2t issues

Posted: Thu Jan 03, 2013 10:59 pm
by mickford
Thanks again Dazzled ... Interestingly inbound calls to the voip number (is that did number) are sent through the router's port services to the ATA no problem - its the calls to PSTN number that are not making it thru regardless of DMZ server ip being set to ATA - all very odd.

Re: Linksys pap2t issues

Posted: Fri Jan 04, 2013 7:34 am
by Dazzled
Lightbulb over head moment! It's clear now. Unfortunately your PAP2T hardware cannot handle PSTN calls. You'll need a separate filtered handset just for PSTN, or else a different ATA.

PSTN signals are analogue. Your router is a strictly digital device and won't pass PSTN down the ethernet to an ATA. ATAs are in part digital back to analogue converters as the standard handset is analogue.

The PAP2T doesn't have a separate PSTN line port. Devices that do (eg Netcomm 210p, Cisco 3102, combined modem-router-ATAs) have 2 input cables and internal switching to whichever line is calling, and the PSTN signal passes through to the analogue handset.