On holidays, x-lite won't register

VOIP setup and troubleshooting
Post Reply
macgreer
Posts: 19
Joined: Sun Sep 21, 2008 9:59 pm
Location: Adelaide

On holidays, x-lite won't register

Post by macgreer » Tue Aug 06, 2013 12:16 pm

Hi, I'm away from home on hols. Mobile phone not working here but have wireless access. I have downloaded x-lite, requested IP approval from exetel for address I am staying at. Put usual info into x-lite, but it won't register. Am I doing everything right? I presume this is possible. Thanks in advance for any clues.
Mac

Dazzled
Volunteer Site Admin
Posts: 6003
Joined: Mon Nov 13, 2006 1:16 pm
Location: Sydney

Re: On holidays, x-lite won't register

Post by Dazzled » Tue Aug 06, 2013 1:28 pm

A VoIP softphone will work on any internet service, provided that VoIP isn't blocked (check the modem firewall). You don't need any special approval. If you have left a VoIP device on and registered at home you may be confusing the system though with two registrations coming through for the same account/number. Since you are using Windows, check also that any added firewall isn't to blame.

I prefer Linphone http://www.linphone.org/ to X-Lite as it is simple to set up and works on most devices and operating systems, but X-Lite should still register. Could you post your config?

If you wish to receive calls, the router will need port 5060 UDP forwarded, or you won't get a ring.

(My family always travel with soft-phone enabled laptops, and we have found many hotels with crudely configured routers that block any port not used by a default Windows installation. Sometimes you can get round this nuisance by using non-standard ports for audio. It's a waste of time talking to the staff - if they can browse their own website the internet must work.)

KavindaS
Forum Admin
Posts: 2506
Joined: Wed Dec 23, 2009 3:59 pm
Location: Sydney

Re: On holidays, x-lite won't register

Post by KavindaS » Tue Aug 06, 2013 2:07 pm

macgreer wrote:Hi, I'm away from home on hols. Mobile phone not working here but have wireless access. I have downloaded x-lite, requested IP approval from exetel for address I am staying at. Put usual info into x-lite, but it won't register. Am I doing everything right? I presume this is possible. Thanks in advance for any clues.
Mac
It may be the basic settings. PM me your voip service number so I can email you the sip settings including loging details.

macgreer
Posts: 19
Joined: Sun Sep 21, 2008 9:59 pm
Location: Adelaide

Re: On holidays, x-lite won't register

Post by macgreer » Wed Aug 07, 2013 12:26 pm

Thanks, but the Linphone link I downloaded has a trojan attached to it
XML2PC_TEST.EXE has Artemis! 22D1EEC4868 - when it unpacks it has the trojan in the BIN folder.
Now I'm glad I paid for McAfee

Dazzled
Volunteer Site Admin
Posts: 6003
Joined: Mon Nov 13, 2006 1:16 pm
Location: Sydney

Re: On holidays, x-lite won't register

Post by Dazzled » Wed Aug 07, 2013 1:44 pm

I'm glad you are safe. Did you go to the Linphone site at http://www.linphone.org/eng/download/pa ... phone.html ? The Windows file there is called linphone-3.6.1-setup.exe. (16.1 MB) The release date was Wednesday 12 June 2013.

I don't have a Windows box handy to see what happens after that. I haven't found an online report.

If you found a virus on the official site, please inform the site - this is widely used software.


PS I did find a report of an infected clone being circulated for Android. Since this is open source software it is likely that someone has fiddled and recompiled the source. Always beware of untrusted sources.

macgreer
Posts: 19
Joined: Sun Sep 21, 2008 9:59 pm
Location: Adelaide

Re: On holidays, x-lite won't register

Post by macgreer » Wed Aug 07, 2013 2:48 pm

Hi, It was from the linphone link posted - I have emailed them to let them know
cheers
Mac

Post Reply