Optus phone hijacks browser with Optus Zoo login

Mobile phone plans, SIM card activation and porting issue
Post Reply
Affinity
Posts: 138
Joined: Thu Feb 12, 2004 4:33 pm

Optus phone hijacks browser with Optus Zoo login

Post by Affinity » Mon Dec 05, 2011 3:54 pm

How can we remove the browser hijacking which wants you to login to Optus Zoo?

I have an Ideos X1 phone that was purchased as Optus pre-pay. The modem works fine as a mobile hotspot, but the internal phone's web browser redirects to the Optus Zoo login screen for new links that open the browser. I don't want to use Optus Zoo, but if I must, then how do I set it up?

My preference is to remove this login screen and to use the browser normally. The problem also occurs when simply using a plain WiFi connection (not 3G or GPRS).

[Edit: I think this is due to the link itself, not an actual hijack]

User avatar
jokiin
Volunteer Site Admin
Posts: 2970
Joined: Mon Feb 02, 2004 10:23 pm
Location: Sydney

Re: Optus phone hijacks browser with Optus Zoo login

Post by jokiin » Mon Dec 05, 2011 4:57 pm

that's the problem with carrier branded handsets, I think you need to root it to remove all that and get it back to a default state, I haven't used that particular model but maybe start here http://forum.xda-developers.com/ and see if anyone has done a firmware for that model already

User avatar
Munka
Posts: 289
Joined: Sat Oct 22, 2005 8:22 pm
Location: Rural NSW

Re: Optus phone hijacks browser with Optus Zoo login

Post by Munka » Mon Dec 05, 2011 4:59 pm

I found this solution on the android forum at whirlpool for removing the optus bloatware, it may or may not suit you but it is the directions for removal on your device. http://forums.whirlpool.net.au/forum-re ... p=10&#r189

Edit: sorry my bad, direction 1: root device.
Edit2: Link to the whirlpool wiki for the x1, simple directions to gain root and get rid of optus branding, and I purchased one of these for an o/s trip. http://whirlpool.net.au/wiki/huawei_x1
Munka

Post Reply