Internal Server Error

Web hosting, FTP/database access, mirror services and hosted blogs
Post Reply
blankdots
Posts: 13
Joined: Sat Oct 10, 2009 10:44 pm
Location: Sydney

Internal Server Error

Post by blankdots » Sat Jan 16, 2010 6:38 pm

I recently deleted my webspace because I couldn't upgrade to Drupal 7 from Drupal 6.
I then created a new webspace. http://home.exetel.com.au/jcventures for a fresh D7 installation.


I placed my D7 installation files via dreamweaver FTP. I can still acess and upload these files through dreamweaver's but not through the standard web ftp://.

When I go to the base folder, I get an internal server error. This also happens if I try to go to http://home.exetel.com.au/jcventures/in ... le=default

I can't run the installation script or see anything but the internal server error when I go to my URL.

The permissions aren't set to global. They are set such that only the owner can write and execute. The permissions are set at 604 for htaccess and other folders.

So whats the problem? Any help would be appreciated?

Thanks

Dazzled
Volunteer Site Admin
Posts: 6003
Joined: Mon Nov 13, 2006 1:16 pm
Location: Sydney

Re: Internal Server Error

Post by Dazzled » Sat Jan 16, 2010 7:49 pm

Start by changing permissions to 705. You have php scripts to execute, and these may be causing the server error. Is the home page a script?

You may get some benefit from a file called phpinfo.php in your space (Use Permission 705). It need contain only the line

Code: Select all

 <? phpinfo(); ?> 
Navigate to it in the browser. You will learn all the features of the site, particularly the full file pathnames and the values of the php variables. Have a squiz at SERVER["SCRIPT_FILENAME"] - it ain't what you guessed, so use reletive names.
Last edited by Dazzled on Sat Jan 16, 2010 8:00 pm, edited 1 time in total.

blankdots
Posts: 13
Joined: Sat Oct 10, 2009 10:44 pm
Location: Sydney

Re: Internal Server Error

Post by blankdots » Sat Jan 16, 2010 7:57 pm

I can only change the htcaccess to 704. All other files remain as 604, i can't seem to change to 705 with dreamweaver.

The home page is a php script, index.php.

I've never had this problem with drupal before, never had to change permissions or anything. Could be the new version.

Dazzled
Volunteer Site Admin
Posts: 6003
Joined: Mon Nov 13, 2006 1:16 pm
Location: Sydney

Re: Internal Server Error

Post by Dazzled » Sat Jan 16, 2010 8:09 pm

705 is basically a cure-all - it always works. The main thing is read permission for owner and others for files.
Can you check what's in index.php? To check nothing's fundamentally wrong, put an .htaccess file somewhere containing

Code: Select all

Options +Indexes
and navigate to that folder in the browser. Alternatively, can the browser display an image file if you navigate directly to it?

Watch the permission of any subdirectories. Normal Linux rules apply.

blankdots
Posts: 13
Joined: Sat Oct 10, 2009 10:44 pm
Location: Sydney

Re: Internal Server Error

Post by blankdots » Sat Jan 16, 2010 8:53 pm

How do I set everything to 705? I set all files to 705 in dreamweaver, and the log seems to show that its succesful. However when I view permissions again, nothing has changed.
I uploaded an impage, but i can't navigate to it directly, the server error shows. Viewing the permissions for the image, its 0, but I can't change it either.

Do I just add JUST the two lines

SELECT ALL
Options +Indexes

into my htaccess file? I've done that and nothing has changed. I would like to watch the permissions of subdirectories, but seeing as I can't change the permissions, I can't really do much. :S

Thanks for your help though so far.

Dazzled
Volunteer Site Admin
Posts: 6003
Joined: Mon Nov 13, 2006 1:16 pm
Location: Sydney

Re: Internal Server Error

Post by Dazzled » Sat Jan 16, 2010 9:05 pm

Only the line Options +Indexes (and only one .htaccess file in the directory). This will instruct Apache to show a directory listing to a visiting browser. The idea is to make sure your site works before we worry about the contents. Any image with read/write permission will also display if you go to it specifically by name. So will phpinfo.php.

I assume you are using Windows with Dreamweaver. Can you get a standard ftp client - see https://www.exetel.com.au/members/ftp_t ... wnload.php

[edit: I see your making progress...]

blankdots
Posts: 13
Joined: Sat Oct 10, 2009 10:44 pm
Location: Sydney

Re: Internal Server Error

Post by blankdots » Sat Jan 16, 2010 9:12 pm

After changing the .htaccess file in the directory, the install.php script is running. I'm not familiar with .htcaccess files.

In the original .htaccess file, there was a Options -indexes. Am i right to assume, that its not safe to leave the code as +indexes?

I'll try the standard ftp, but i've had problems in the past. At least something displays now.

Dazzled
Volunteer Site Admin
Posts: 6003
Joined: Mon Nov 13, 2006 1:16 pm
Location: Sydney

Re: Internal Server Error

Post by Dazzled » Sat Jan 16, 2010 9:13 pm

+Indexes forces a contents display. I doubt you want that once it is running, so only for testing. The web space itself is functional, so that part is over.

You can read this up if you like - http://javascriptkit.com/howto/htaccess.shtml

blankdots
Posts: 13
Joined: Sat Oct 10, 2009 10:44 pm
Location: Sydney

Re: Internal Server Error

Post by blankdots » Sat Jan 16, 2010 9:33 pm

Yeah Thanks for your help.

Is there a way to use CHMOD manually?
I think its a permissions problem.

Dazzled
Volunteer Site Admin
Posts: 6003
Joined: Mon Nov 13, 2006 1:16 pm
Location: Sydney

Re: Internal Server Error

Post by Dazzled » Sat Jan 16, 2010 9:40 pm

Dead simple if you are on Linux - you can enter a remote ftp site as if it's on your own machine, and use the built-in functions. On Windows you will need an ftp client, as in my earlier post. Most of them change permissions with a right click. They don't all use old style octal notation however, some have a GUI. (705 for example is boxes ticked as - owner=r,w,x; group=-,-,-; others=r,-,x)

Server errors suggest that your scripts are asking something Apache cannot or should not do. For security reasons, your browser will not be told any details.
Attachments
chmod.png
chmod.png (18.39 KiB) Viewed 1437 times

blankdots
Posts: 13
Joined: Sat Oct 10, 2009 10:44 pm
Location: Sydney

Re: Internal Server Error

Post by blankdots » Sat Jan 16, 2010 9:52 pm

Hmm.

In the original HTaccess file, there were these two lines

# Follow symbolic links in this directory.
Options +FollowSymLinks

By removing the code line, the scripts are running.

Dazzled
Volunteer Site Admin
Posts: 6003
Joined: Mon Nov 13, 2006 1:16 pm
Location: Sydney

Re: Internal Server Error

Post by Dazzled » Sat Jan 16, 2010 10:00 pm


Post Reply