forbidden

VOIP setup and troubleshooting
no1joe
Posts: 4
Joined: Sat Apr 26, 2014 3:37 pm
Location: Townsville

forbidden

Post by no1joe » Tue Nov 10, 2015 11:31 am

c-sip-simple was working fine untill recently i get forbidden. have you changed something? my service still works on x-lite on the computer

asankag
Exetel Staff
Posts: 77
Joined: Tue Jun 12, 2012 3:22 pm
Location: Sydney

SL-admin

Post by asankag » Tue Nov 10, 2015 5:00 pm

Hi no1joe,

Exetel introduced a security feature some time ago when it comes to outbound calls. Your account is currently restricted to make outbound calls from Exetel IP ranges only.

To modify this setting, simply login to your account and navigate to Services & Usage -> Click Manage next to your VOIP number -> VoIP Configuration -> VoIP Access from and select the best option for your use case.
---
Regards,
Asanka | L2 - VoIP Engineer

no1joe
Posts: 4
Joined: Sat Apr 26, 2014 3:37 pm
Location: Townsville

Re: forbidden

Post by no1joe » Tue Nov 10, 2015 5:43 pm

I'm using it connected to the nbn via wireless on the same router the computer is connected to via lan cable.

asankag
Exetel Staff
Posts: 77
Joined: Tue Jun 12, 2012 3:22 pm
Location: Sydney

Post by asankag » Tue Nov 10, 2015 6:40 pm

Hi no1joe,

I've just tested your account on c-sip-simple and was able to register without any issues. Can you please double-check the password you're using.
---
Regards,
Asanka | L2 - VoIP Engineer

no1joe
Posts: 4
Joined: Sat Apr 26, 2014 3:37 pm
Location: Townsville

Re: forbidden

Post by no1joe » Thu Nov 12, 2015 3:56 pm

well i don't know there's not that many settings and i didn't change anything
i recopied the password from the setup email i got still, no go. recopied on computer too cant be password
the settings I'm using are
username 07--------
authentication same as username
sip1.exetel.com.au or sip1.exetel.com.au:5060 or 58.96.1.2....various combinations of in server and proxy
I've checked my router ports, even extended them from 5000-6000
the application hasn't been updated recently
tried my phone too, didn't work.


[number edited by Dazzled, for user's privacy]

asankag
Exetel Staff
Posts: 77
Joined: Tue Jun 12, 2012 3:22 pm
Location: Sydney

Re: forbidden

Post by asankag » Fri Nov 13, 2015 10:20 am

Hi,

Will yo be able to post some screenshots? Here's mine. I tested again over my Data connection and was able to connect without any issues.

Accounts settings page:
Screenshot_2015-11-13-04-34-05.png
Account settings
Screenshot_2015-11-13-04-34-05.png (123.15 KiB) Viewed 4003 times
Shows Successful registrations:
Screenshot_2015-11-13-04-43-09.png
Accounts screen
Screenshot_2015-11-13-04-43-09.png (165.74 KiB) Viewed 4003 times
---
Regards,
Asanka | L2 - VoIP Engineer

Arn
Posts: 14
Joined: Sun Sep 12, 2004 12:30 am

Re: forbidden

Post by Arn » Tue Jan 05, 2016 10:37 pm

I get the same problem; I used to be able to use CSIPSimple on my Nexus 5, though the call quality was choppy, so I stopped using it for a long while. Now (and a few Android versions later - now on Marshmallow) I get the same error as the OP does. I have done the same settings as the screenshots above, but get a "forbidden" error. Any more suggestions?

Dazzled
Volunteer Site Admin
Posts: 6003
Joined: Mon Nov 13, 2006 1:16 pm
Location: Sydney

Re: forbidden

Post by Dazzled » Wed Jan 06, 2016 8:22 am

Forbidden while registering has a history - see entries at code.google. I don't know the solution, but you might try using Linphone, which is also open source. Linphone runs on most platforms.

Arn
Posts: 14
Joined: Sun Sep 12, 2004 12:30 am

Re: forbidden

Post by Arn » Wed Jan 06, 2016 10:29 am

Thanks for the reply. I'm really not having much luck with VOIP apps - I can't get past a "Registration failed" error with Linphone, though I'm sure I'm using the right settings. Also tried Zoiper after reading another thread in these forums, which seems to register OK, but I can't seem to make calls. I'm using my VOIP phone number, the password I was issued at the start, and either 58.96.1.2 or sip1.exetel.com.au. Are there any other settings that I would need to check? Thanks!

Arn
Posts: 14
Joined: Sun Sep 12, 2004 12:30 am

Re: forbidden

Post by Arn » Wed Jan 06, 2016 10:42 am

My problem with Linphone may have been that I was trying lots of different clients together; I can make calls with it now. Still can't get Zoiper to make calls, out, though.

KavindaS
Forum Admin
Posts: 2509
Joined: Wed Dec 23, 2009 3:59 pm
Location: Sydney

Re: forbidden

Post by KavindaS » Wed Jan 06, 2016 11:50 pm

Arn wrote:My problem with Linphone may have been that I was trying lots of different clients together; I can make calls with it now. Still can't get Zoiper to make calls, out, though.
I have tested your voip number using my Zoiper application and it is working fine with the out calls. If the issue is persisting, you may get some screen captures of the Zoiper set up page and send it to smbsupport@exetel.com.au

Arn
Posts: 14
Joined: Sun Sep 12, 2004 12:30 am

Re: forbidden

Post by Arn » Fri Jan 08, 2016 8:26 pm

Thanks for doing that Kavinda. I tried again and it works now, so it was probably affected by my experimentation with Linphone. I was able to make a call, though the recipient complained that the call was choppy and hard to understand. Are there any particular settings I should use for it to make the call better quality?

fsm
Posts: 77
Joined: Thu Apr 01, 2010 10:46 pm
Location: Aus

Re: forbidden

Post by fsm » Fri Mar 18, 2016 5:16 am

I looked into my "forbidden" which has been happening to me for quite a while now. The workaround I discovered was to enable STUN in CSipSimple when NATs are involved and wait 20 mins or so for the SIP server to expire the lockout. It seems that Exetel's servers now object to private IP addresses in SIP REGISTER packets whereas previously they would work around this. Adding the private addresses as a custom address does not workaround the problem.

Could Exetel support please restore the previous behaviour and ensure their VOIP service works with deficient NATs such as the AU carrier NATs without special configuration. STUN is not capable of correctly determining public addresses in all NAT configurations.

I also noticed that Exetel no longer supports passing DTMF via RFC2833 RTP packets. It's SIP INFO or nothing. Could this and preferably all methods of passing DTMF be supported.

dulipf
Exetel Staff
Posts: 123
Joined: Tue Mar 10, 2015 2:56 pm
Location: Australia

Re: forbidden

Post by dulipf » Fri Mar 18, 2016 8:40 am

fsm wrote:I looked into my "forbidden" which has been happening to me for quite a while now. The workaround I discovered was to enable STUN in CSipSimple when NATs are involved and wait 20 mins or so for the SIP server to expire the lockout. It seems that Exetel's servers now object to private IP addresses in SIP REGISTER packets whereas previously they would work around this. Adding the private addresses as a custom address does not workaround the problem.

Could Exetel support please restore the previous behaviour and ensure their VOIP service works with deficient NATs such as the AU carrier NATs without special configuration. STUN is not capable of correctly determining public addresses in all NAT configurations.

I also noticed that Exetel no longer supports passing DTMF via RFC2833 RTP packets. It's SIP INFO or nothing. Could this and preferably all methods of passing DTMF be supported.
Hi fsm,

We will check this with our senior VoIP engineers and get back to you with an update. Ref#10062739

dulipf
Exetel Staff
Posts: 123
Joined: Tue Mar 10, 2015 2:56 pm
Location: Australia

Re: forbidden

Post by dulipf » Tue Mar 29, 2016 6:51 am

Our senior VoIP engineers have advised no changes have been made from their end in regards to the behavior of the VoIP Services.

They believe the issue you might be experiencing might probably be an issue with the mobile carrier setup.

Post Reply