Used to be good

Comments and posts about your experience with Exetel
Post Reply
Dr.Gerry
Posts: 11
Joined: Tue Nov 17, 2015 7:47 pm
Location: Coolongolook

Used to be good

Post by Dr.Gerry » Sat Feb 02, 2019 12:28 pm

I first connected to Exetel in 2014. At the time I was really impressed with their service. I live in a small town and we got the NBN (wireless) way back then, so I have been pretty lucky, internet-wise. We always got good download speeds - it was rare to get anything below 40Mb (once we moved to the 50Mb fixed wireless plan). We could have every member of the family (4) either streaming something or playing online gaming and it worked for all of us. I used to tell anyone who asked me that at least in my experience, Exetel was one of the hidden gems of the NBN.

Sadly, that has all changed. The speed has dropped off so badly that at peak times, 2 Mb is a pretty good speed. During the day, it's not much better - on a 50Mb plan you would expect to get at least 40Mb, but we struggle to get over 15. I have sent an email to Exetel support just asking them to check that somehow I hadn't been 'accidentally' dropped back to a 25Mb service. I received no reply.

To add insult to injury, Exetel seem happy to screw their current customers. There's an offer on the front page at the moment - unlimited 50Mb (the SAME as the plan I am on) for $59 per month. So anyone can walk in off the street and get a better deal than someone who has been a loyal customer for a number of years. I emailed Exetel about this one, and they said that even though it is the same plan, I can't get it because I qualify for special regional pricing, apparently! Yay! Lucky me - I live in a regional area so I get the sucker price of $20 more per month.

Most people would ask why I haven't changed providers, well, I currently have a couple of browser tabs open comparing other providers. Personally I'd be happier if Exetel just fixed my service and gave me what I pay for. I'm pretty certain that given the bureaucratic blundering that sometimes happens at the NBN Office, changing providers might just be a one way ticket to internet perjury.....so I have been giving Exetel '1 more chance' for quite a long time now, but that time is nearly up.

Dhilshan
Exetel Staff
Posts: 229
Joined: Sat Jan 06, 2018 12:22 pm
Location: Sydney

Re: Used to be good

Post by Dhilshan » Sat Feb 02, 2019 4:23 pm

Hi there,

Sorry to hear that the service is not meeting your expectation. We would like to review your case further and provide a quick solution. Therefore, could you please drop an email to residentialsupport@exetel.com.au or PM your service details so we can check the status of this query.

James
Exetel Staff
Posts: 1991
Joined: Mon May 09, 2005 10:27 pm

Re: Used to be good

Post by James » Sun Feb 03, 2019 12:45 pm

Dear Gerry,

I'm sorry you are having speed issues, but this is a known issue with many wireless NBN services, and not something that Exetel nor any other NBN customer can fix. NBN though have committed to fixing most of these issues by September this year; https://www.google.com/search?client=fi ... congestion

In terms of the price, in regional Australia it costs Exetel more to get connectivity from your local Point of Interconnect (POI), back to our network, so in some regional areas the price is $20.00 more than in metro areas.

James

Dr.Gerry
Posts: 11
Joined: Tue Nov 17, 2015 7:47 pm
Location: Coolongolook

Re: Used to be good

Post by Dr.Gerry » Wed Feb 20, 2019 8:45 am

Hi James,

Don't know if anyone has looked at my account yet, but my speed seems to have improved out of sight. Every speed test I have done lately we have achieved more than 40 Mb, so that's a massive improvement. Thanks

Mow my only beef is that the network seems to go down every day for a few hours. I assume this may be part of ongoing repairs/work on the network as it has been happening since you had a NSW-wide network outage a week or two ago.

Gerry

James
Exetel Staff
Posts: 1991
Joined: Mon May 09, 2005 10:27 pm

Re: Used to be good

Post by James » Wed Feb 20, 2019 10:51 am

Dear Gerry,

There has been no change to the Exetel network, this would be a local NBN Co upgrade to the infrastructure in your area.

James

Dr.Gerry
Posts: 11
Joined: Tue Nov 17, 2015 7:47 pm
Location: Coolongolook

Re: Used to be good

Post by Dr.Gerry » Fri Mar 01, 2019 9:11 am

Hi James,

Our service has now been down for well over a day. We have tried resetting all our gear. Your support line does not mention any outages. I dont know if you are trying to fob me off by saying it is a local NBN problem, but as our provider it is YOUR problem.

We have spent a fortune on mobile data to get our internet for the last few days. This is totally unacceptable.

This has now gone to the point where i will be contacting the ombudsman and i will be making a claim for a) a refund of our fees for the last month at least, as you have sold us a service you are obviously not able to provide, and b) reimbursement of our mobile data expenses.

If you can fix this problem I request that you do it today please or i will contact the ombudsman this afternoon

Gerry

James
Exetel Staff
Posts: 1991
Joined: Mon May 09, 2005 10:27 pm

Re: Used to be good

Post by James » Fri Mar 01, 2019 9:36 am

HI Gerry,

If there is a local NBN issue then there is nothing that Exetel nor any other NBN RSP can do apart from wait.

Going to the TIO will do nothing but cost Exetel unnecessary fees and achieve nothing in terms of speeding up your service repair time, in fact it will probably increase it as it that is handled by our compliance team then our support team.

I am sorry you are having an issue, but our team would be doing everything possible to resolve it, as we certainly do not want unhappy customers.

James

Dr.Gerry
Posts: 11
Joined: Tue Nov 17, 2015 7:47 pm
Location: Coolongolook

Re: Used to be good

Post by Dr.Gerry » Fri Mar 01, 2019 9:59 am

Hi James,

If it was a local NBN issue wouldnt you guys at least know about it and be able to advise accordingly? Isnt that what your 'current outages' should show?

My reason for going to the TIO is to try to pursue some sort of refund for the service you are charging me for and not providing (the Banking Royal Commission has shown that charging for a service you dont provide is not acceptable), and to recoup expenses incurred in trying to work around the issue.

Gerry

James
Exetel Staff
Posts: 1991
Joined: Mon May 09, 2005 10:27 pm

Re: Used to be good

Post by James » Fri Mar 01, 2019 10:15 am

Hi Gerry,

We do not show local issues, we only show major issues.

Why not contact our billing team once the outage has been resolved and ask them for a refund? I'm sure they would be happy to help.

Not sure how the banking royal commission is relevant here, but if you feel so strongly about your treatment by Exetel, then perhaps another provider is best?

James

Dr.Gerry
Posts: 11
Joined: Tue Nov 17, 2015 7:47 pm
Location: Coolongolook

Re: Used to be good

Post by Dr.Gerry » Fri Mar 01, 2019 11:26 am

Hi James,

Sorry - the royal commission thing was a bit of a stretch.

I would rather not change if possible. As i have said, i always regarded you guys as a pretty good provider, and recently the speed has been good when the connection is working.

Thanks for the tip re contacting the billing department. I had just assumed that you probably wouldnt be open to any sort of refund or anything....so sorry for pre-judging!

Gerry

Dr.Gerry
Posts: 11
Joined: Tue Nov 17, 2015 7:47 pm
Location: Coolongolook

Re: Used to be good

Post by Dr.Gerry » Mon Mar 11, 2019 2:33 pm

Hi James,

What is the process for cancelling my Exetel account?

Gerry

James
Exetel Staff
Posts: 1991
Joined: Mon May 09, 2005 10:27 pm

Re: Used to be good

Post by James » Mon Mar 11, 2019 8:11 pm

Hi Gerry,

Call up the sales team and they can assist you, but the issues you are having are NBN, nothing will change with another RSP.

James

Dr.Gerry
Posts: 11
Joined: Tue Nov 17, 2015 7:47 pm
Location: Coolongolook

Re: Used to be good

Post by Dr.Gerry » Mon Mar 11, 2019 10:20 pm

Hi James,

Sorry - I'd really like to believe you, but my new service was activated today. I have not had a working internet connection with you guys since last Friday - it has been off all weekend, and was off this morning. I received my Telstra modem at about 9 am. I connected it, called their customer support, and my service was activated at around 10 am, and guess what - it works. It has worked all day. Your service hasn't worked for 3 days, but as soon as I plugged the Telstra modem in, everything worked. It was quite clearly NOT an NBN problem.

It is this sort of unreliability and refusal to accept that you may have some sort of a problem that has caused me to change providers. I think I have a pretty good idea of what your problem was, and if I am right, I am not surprised you tried to dissuade me from going to the TIO.

Gerry

Post Reply